Problems BGP load balance Route default

Unanswered Question
Mar 22nd, 2008
User Badges:

i am with a question of how the bgp makes the load balancing, i have the environment as annex.

the output of the command "show ip route" does not appear the route of the second AS announced only one line appears below


R4#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route


Gateway of last resort is 193.10.0.1 to network 0.0.0.0

191.10.0.0/24 is subnetted, 1 subnets

C 191.10.0.0 is directly connected, Serial1/1

C 193.10.0.0/24 is directly connected, Serial1/0

C 194.10.0.0/24 is directly connected, FastEthernet0/0

B* 0.0.0.0/0 [20/0] via 193.10.0.1, 00:55:33

R4#

the bgp does not offer the chance to take a load balance with AS different, I did the test with R2 and R3 in the same AS and worked, after re-configuration performed the command "show ip bgp" appear the 2 AS.


R4#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is 193.10.0.1 to network 0.0.0.0

191.10.0.0/24 is subnetted, 1 subnets

C 191.10.0.0 is directly connected, Serial1/1

C 193.10.0.0/24 is directly connected, Serial1/0

C 194.10.0.0/24 is directly connected, FastEthernet0/0

B* 0.0.0.0/0 [20/0] via 193.10.0.1, 00:55:33

[20/0] via 191.10.0.1, 00:55:33

R4#


I am using dynamips with image for the 7200 router to simulate the environment will be some bug or some configuration of dynamips wrong. Below the configuration of each router


R2

interface Serial1/0

ip address 172.16.0.2 255.255.0.0

serial restart-delay 0

no clns route-cache

!

interface Serial1/1

ip address 193.10.0.1 255.255.255.0

serial restart-delay 0

clockrate 64000

no clns route-cache

!

router bgp 20

no synchronization

bgp log-neighbor-changes

neighbor 193.10.0.2 remote-as 40

neighbor 193.10.0.2 default-originate

neighbor 193.10.0.2 soft-reconfiguration inbound

no auto-summary


R3

interface Serial1/0

ip address 192.168.0.2 255.255.255.0

serial restart-delay 0

clockrate 64000

no clns route-cache

!

interface Serial1/1

ip address 191.10.0.1 255.255.255.0

serial restart-delay 0

no clns route-cache

!

router bgp 30

no synchronization

bgp log-neighbor-changes

neighbor 191.10.0.2 remote-as 40

neighbor 191.10.0.2 default-originate

neighbor 191.10.0.2 soft-reconfiguration inbound

no auto-summary


R4

interface FastEthernet0/0

ip address 194.10.0.1 255.255.255.0

duplex half

no clns route-cache

!

interface Serial1/0

ip address 193.10.0.2 255.255.255.0

serial restart-delay 0

no clns route-cache

!

interface Serial1/1

ip address 191.10.0.2 255.255.255.0

serial restart-delay 0

clockrate 64000

no clns route-cache

!

router bgp 40

no synchronization

bgp log-neighbor-changes

neighbor 191.10.0.1 remote-as 30

neighbor 193.10.0.1 remote-as 20

maximum-paths 2

no auto-summary

!

Also performed a series of commands from diagnosis as below.


R4#show ip bgp

BGP table version is 23, local router ID is 194.10.0.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

* 0.0.0.0 193.10.0.1 0 40 20 i

*> 191.10.0.1 0 40 30 i

R4#

If anyone has any hint of where to be incorrect already grateful, follow the following tutorial http://www.ccnalab.net/load_sharing_bgp.php


Sincerely

Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joseph W. Doherty Sat, 03/22/2008 - 16:46
User Badges:
  • Super Bronze, 10000 points or more

You don't appear to have the AS prepends (on R4) as described in the lab note.

r-barbosa Sat, 03/22/2008 - 16:53
User Badges:

Sorry, is yes, just forgot to illustrate below


router bgp 40

neighbor 191.10.0.1 remote-as 30

neighbor 191.10.0.1 route-map prepend-as in

neighbor 193.10.0.1 remote-as 20

neighbor 193.10.0.1 route-map prepend-as in

neighbor 193.10.0.1 soft-reconfiguration inbound

maximum-paths 2


route-map prepend-as permit 10

set as-path prepend 40


Sincerely

Joseph W. Doherty Sat, 03/22/2008 - 17:31
User Badges:
  • Super Bronze, 10000 points or more

That's looks good. Looking again at your original post, I see:


R4#show ip bgp

BGP table version is 23, local router ID is 194.10.0.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

* 0.0.0.0 193.10.0.1 0 40 20 i

*> 191.10.0.1 0 40 30 i


So, we see the prepend is applied to both R2 and R3, both default paths are in the BGP table, but it's picking the lower IP address path. I.e. it's acting like multipath isn't active. (I think I recall, BGP multipath shows up somewhere in the show ip bgp output, when active. If true, don't see it in your output.)


Try a "clear bgp *" on R4.

r-barbosa Sat, 03/22/2008 - 19:48
User Badges:

hi, already tried to the command "clear ip bgp asn", depending on who makes the router adjancency first this becomes the default route, which will be a bug in the simulator? You already had some environmental equal to this that I am trying to simulate?


Sincerely

Joseph W. Doherty Sat, 03/22/2008 - 20:54
User Badges:
  • Super Bronze, 10000 points or more

"some environment", no not exactly, but I have used eBGP multipath in production environments; not using default routes, nor using the lab's own AS prepend technique, however.

r-barbosa Sat, 03/22/2008 - 23:01
User Badges:

An interesting point when i do shutdown in the serial R2 or R3, the other assumes the path to default route in R4


Sincerely

Joseph W. Doherty Sun, 03/23/2008 - 04:39
User Badges:
  • Super Bronze, 10000 points or more

That would correspond with the fact that both paths for default are in your BGP table. Does the best path alway flip? I.e. if the best path is via R3, and you shutdown the serial to R3, does the best path remain with R2 after R3 is restored, or does if flip back to R3?


One thing you might try is advertise 10.0.0.0/8 from R1. See if it too appears twice in you BGP table, and whether as a multipath or just one path.

Actions

This Discussion