Round robin algorithm not correct for CSS

Unanswered Question
Mar 23rd, 2008

Hi,

Recently we have upgraded our CSS from 11000 Series to 11503. I encounter an unusal problem with the HTTP to HTTPS redirection.

Total Servers to redirect for HTTP to HTTPS Service=>4

The round robin of the CSS 11503 will behave this way, Server1, Serve2, Server2, Server3..Server1...and so on....

and the total Service hit counts is not the same. It did not complete a rr cycle and there is repeat servers within a "cycle"

When I tried to input the same config of the services back to CSS11000 and it works fine: Server1, Server2, Server3, Server4, Server1....and so on (no repeat the rr work fine)

What could be the problem?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Gilles Dufour Sun, 03/23/2008 - 14:04

The 11500 is a multiprocessor architecture.

Each processor doing roundrobin indepently.

So, with a very low number of connections you can see uneven loadbalancing.

However, in a production network, with lots of connections, the difference should be very low.

Gilles.

gerrylim Sun, 03/23/2008 - 18:47

Hi Gilles,

Thanks for the reply. That certainly helps to clear up the confusion.

Is there any way for me to verify the multiprocessor architecture on the CSS 11503?

Perhaps running some commands on CSS to show the number of processors? Or help to provide a link to the CSS data sheet or Specification which show this info?

Gilles Dufour Mon, 03/24/2008 - 04:07

you can do a 'flow stat' to see what traffic each processor handles.

There is a processor in each card you have in the CSS.

So, one in the SCP.

And if you have another module IO module, you also a processor there.

Traffic is splitted between the modules whatever the interface the come in.

Gilles.

gerrylim Mon, 05/05/2008 - 23:22

We have 3 modules in CSS 11503,

1.SS5-SCM-2GE

2.CSS5-SAM

3.CSS5-IOM-8FE

Due to application requirement, we desperately need to load balance through Round Robin method and must be in order

s1->s2->s3->s1->s2->......and so on

and not s1->s1->s2->s3->s1->s2->s2...and so on

Is there a way to workaround or turn off this multiprocessor architecture? Perhaps configuration???

Actions

This Discussion