SIP Trunk

Unanswered Question
Mar 23rd, 2008

Hi,

I am trying to configure a SIP account on my 2801 ISR Router using the CUBE functionality. I have tried all possible configuration combinations but it does not seem to register. The account works fine if I use a softphone such as X-Lite. My configuration details are as follows:

sip-ua

authentication username xxxxxxxxxx password xxxxxxxxxx realm byo.engin.com.au

credentials username xxxxxxxxxx password xxxxxxxxxx realm byo.engin.com.au

registrar dns:byo.engin.com.au expires 3600

sip-server dns:byo.engin.com.au

!

My Voip service provider is engin and the settings they provided me for an Asterisk setup were:

auth=md5

canreinvite=yes

dtmfmode=rfc2833

fromdomain=voice.mibroadband.com.au

fromuser=XXXXXXXXXX

host=byo.engin.com.au

insecure=very

musiconhold=framed

nat=yes

port=5060

qualify=no

realm=mobileinnovations.com.au

reinvite=yes

secret=password

type=friend

username=XXXXXXXXXX

Some explanation on

1) authentication vs credentials and

2) as well registrar vs sip-server

under sip-ua configuration would be much appreciated.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Mon, 03/24/2008 - 04:01

1 authentication is for placing calls, credential to register.

2 registar is what handles registrations INTO router. sip-sever handles calls. How course the two things are tied.

now for the proble, do you have an Ip-to-ip image (filename ends in _ivs) ? NAd what specific problem do you have (can't register, can't call or what) ?

Nelson Serrao Tue, 03/25/2008 - 02:54

Thanks for the info. I have the following IOS: c2801-ipvoice_ivs-mz.124-15.T3.bin

The problem is that it does not register at all.

Nelson Serrao Wed, 03/26/2008 - 00:05

************Configuration***************

sip-ua

credentials username xxx password xxx realm dns:mobileinnovations.com.au

authentication username xxx password 12345 realm dns:mobileixxx.com.au

retry options 1

registrar dns:byo.engin.com.au expires 900

sip-server dns:byo.engin.com.au

************Error from debug ccsip************

SIP/2.0 407 Proxy Authentication Required

To: [email protected]>;tag=ds33af16c

From: [email protected]>;tag=1AE749F0-1079

Via: SIP/2.0/UDP 192.168.100.68:5060;branch=z9hG4bK17EAD2

Call-ID: 312B86F3-FA3911DC-8235F0DB-1DB97FC5

CSeq: 4 REGISTER

Date: Wed, 26 Mar 2008 07:00:28 GMT

Proxy-Authenticate: Digest realm="mobileinnovations.com.au",domain="sip:byo.engi

n.com.au:5060",nonce="xuQCcKjtvrRVuayrJq4kIg==_40f0",qop="auth"

Content-Length: 0

Paolo Bevilacqua Wed, 03/26/2008 - 03:06

Router should continue with another registration message containing authentication, does not ?

Nelson Serrao Sat, 03/29/2008 - 17:18

I did some further troubleshooting and realised that the config on the router is perfect. When I use an ADSL connection, the SIP trunk registers well. However, when I use the corporate internet connection which is a secure MPLS service, it does not work. I requested the ISP to forward udp ports 5060 and 16384-20384 to the router ip address. Despite this, it does not work. Is there something more to be done? Config and debug files attached.

Attachment: 

Actions

This Discussion