Scenario - Cannot ping locally using manually configured ip.

Unanswered Question
Mar 24th, 2008

Good Day Everyone,

I have a problem that I have been trying to resolve and seeking some input. I have attached config files and visio drawing for scenario accuracy.

I have 2 3560 switches communicating through 2 wireless bridges correctly and trunking vlans but I'm having a few issue's at the remote office with the voice vlan. The data vlan is working fine.

I can ping the devices on the voice vlan at the main office from the remote office switch through the console cable, but when I plug in my laptop to the remote office switch and assign a valid ip address and subnet mask in the voice vlan ip range and try to ping a device on the voice vlan at the main office the ping will timeout.

Note: We are not using dhcp on the voice vlan, we are using dhcp on the data vlan.

Any guidance would be appreciated.

I have tried different ports, different port config's with no luck. I have verified the port vlan membership, vlan status. Im wondering if it's something im missing in my config.

I must also add that I cannot ping my laptop with the manual assigned ip from the console of the switch it's connected to.



NOTE: Diagram is not exact. vlan info should be pulled from config

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (3 ratings)
mattcalderon Mon, 03/24/2008 - 18:55

The issue is that you are trying to put a laptop on a VOICE vlan. Voice vlans are a cisco vlan for ip phones.

Excerpt from below guide:

the voice VLAN feature enables access ports to carry IP voice traffic from an IP phone

You are trying to put your laptop in a voice vlan and it does not work like that. If you were to attach a phone with the same static ip, i believe it will work.

I would put a phone on the voice vlan and then attempt to ping the phone from the main office. This would be let you know your network is set up correctly.

evsrajatgupta Tue, 03/25/2008 - 05:17

Hi Justin,

Mattcalderron is right.

Your ports on the remote is configuration with both voice and data vlan. Thus when you plug a laptop, the switch tag it with data-VLAN by default not voice-vlan.And the IP address you assigned is a mismatch (IP address os voice and vlan of data).

I am sure if you assign the Data vlan ip to laptop you will be able to ping the voice device also provide inter-Vlan routing permits so.

legerity1_2 Tue, 03/25/2008 - 07:24


When you set the voice vlan on a port, you are essentially telling the switch to send 802.1q tagged packets it receives to the voice vlan. Your laptop doesn't send packets tagged, so as pointed out, you don't get connectivity. As a general rule on voice enabled ports tagged packets will automatically be sent into the voice vlan and untagged packets will go to the access vlan. This can occur whether a trunk is negotiated between the phone and switch or not, as in 3com phones on Cisco switches.

If you need to test voice vlan connectivity, you'll have to assign a port to vlan 25 as the access vlan, so:

switchport access vlan 25

You can remove the voice vlan for testing (no switchport voice vlan 25), but it should work with both the voice and access vlans set to the same vlan. You should be able to assign your laptop an ip in vlan 25, plug it directly into the switch port you reconfigured, and then test end to end connectivity in your voice vlan.



mattcalderon Tue, 03/25/2008 - 07:48

Very nice explanation. That's what I was trying to get across but in terms not so detailed!

Justin Brenton Tue, 03/25/2008 - 08:09

Thanks Guys, Much appreciated. It's great to have such a resource and that everyone is so eager to help. You won't see this with Nortel. :)

I have voted for both of your help.


This Discussion