WLC 4402 cannot register APs

Unanswered Question
Mar 24th, 2008
User Badges:

hey


my wireless network has 20 LAPS,recently my controller lost 11 LAPS,i did a reboot on the controller and the remaining 9 LAPS were also lost.


i have tried several suggestions but nothing has workd


i upgraded the controller from 3.2.119. image to 4.0.219.0.i also changed to LAPS from LAPS to APS and back but nothing seem to work.


does anyone have an idea as to what the problem might be.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
m-geisler Thu, 03/27/2008 - 13:17
User Badges:

Hmm, I had a similar problem. Solved it by reverting the controller to 3.2.(whatever).

but first check if the APs are upgrading that takes sometimes longer than the official 5 min.

Good luck

Michael

sabhasin Thu, 03/27/2008 - 21:26
User Badges:

do you see anything on the controller (while running debug lwapp events enable)? How are the APs and the controller connected to the network?

akobwaycct Thu, 03/27/2008 - 23:06
User Badges:

no i don see anything in the controller absolutely nothing,even the laps cannot get a lwapp response from the controller after issueing a lwapp request.


please see the attached diagram of how the laps and the controller are connected to the network.



Attachment: 
mirek.tichy_2 Fri, 03/28/2008 - 00:56
User Badges:

Hello,

your topology is not trivial. I would say :

1) be sure about propper IP layer configuration - ping from the controller to LAPs

2) what about the controller discovery on LAPs ? If the LAPs know the right conntroller you must see a registration attempts. Try to switch on "debug lwapp events", "debug lwapp packets" and "debug lwapp errors". Best to try on only one LAP.

3) on older converted APs there can be a problem with a certificate. It can be watched on the WLC by "debug pm pki"

I have had LAP registration problems many times but it was always some stupid mistake.


akobwaycct Fri, 03/28/2008 - 05:33
User Badges:

i cannot ping from the controller to any laps because the controller is supposed to assign ip addresses to the LAPS so if the Laps cannot register with the controller then i cannot ping any of them.


i have tried your suggestion at some point but like i said when the lap issues a lwapp discovery it cannot find the controller.


ip configs are ok, that i am sure of beacuse the same config was working before.

mirek.tichy_2 Fri, 03/28/2008 - 05:54
User Badges:

For the LWAPP registration the LAP needs to be given by a valid IP address. So there must be a short time period before rebooting the AP has a correct IP address and starts the registration. On console of the LAP you can see it by "show lwapp ip config". Moreover if the WLC is behind router you need properly configured DHCP option 43 or DNS config for the WLC discovering. Can you see the registration requests on WLC's debug lwapp?

akobwaycct Fri, 03/28/2008 - 07:42
User Badges:

the LAP does not get an address i confirmed that,hey recently the IT department change their DHCP server,what is configured in the WLC is now a relay to the DHCP server and the controller is seating behind a cisco 6509.


Do you think it could be the issue of cofiguring DHCP option 43.

mirek.tichy_2 Fri, 03/28/2008 - 14:04
User Badges:

Hi,

on the Cisco 2611 router there has to be an "ip helper-address" pointing to the right DHCP. Try another thing. Take one of the LAPs and connect it to the WLC managemnent VLAN on the Cat 6509. In this case you don't need the option 43.

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode