Unknown VPI/VCI (ADSL)

Unanswered Question
Mar 25th, 2008
User Badges:

I am having trouble connecting to my ISP (ADSL via my 1841/Wic-1ADSL).


I have followed this configuration to a T:

http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a008071a6c3.shtml


But haven't had any success. I know the problem lies in the VPI/VCI pairing, and I have incorrect settings.


And normally, this is where one would call their ISP and get the correct information. Unfortunately - for myself - after calling their tech support line, I received the following help "if you're having trouble with your Cisco router, you need to call Cisco"


I was floored to say the least, but as my ISP is OCN NTT out of Japan, there's not much I can do since there's a bit of a communication gap between English and Japanese.


I've found a few great sites that are repositories for VPI/VCI pairs for ISPs in America - but nothing for this side of the world.


Would anybody know were I can go to get some more information on this?


Another option, if possible - does anybody know of an application to detect the pvc numbers (as I've temporarily returned to my original setup of a DSL modem provided by the ISP - until I can put the Cisco router into production).


Thank you very much for any assistance you can provide.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
paolo bevilacqua Tue, 03/25/2008 - 06:35
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Would you try 0/35. Also you can search for the modem brand they gave, see if you can conenct to it someway, and read the values from there.

usslindstrom Wed, 03/26/2008 - 05:02
User Badges:

Thank you very much for the information.


Using the part number from the old modem - I was able to scrounge up through google some documentation on it.


Unfortunately, it's in Japanese - so it's a bit rough around the edges...


But here's what I can get from it:


LLC Encapsulation

VPI/VCI: 0/32

Line Mode: Auto G.dmt or G.lite

Allow PPPoE:


Unfortunately, even with all those settings, I'm sorta' shooting in the dark. I've gone through the setup over and over, and the ATM interface only reports that it's "initializing" - and that's where it gets stuck at.


Would somebody be able to shed some light on this situation?


Here's my current config for the wic-1adsl:


interface ATM0/0/0

no ip address

no atm ilmi-keepalive

bundle-enable

dsl operating-mode auto


interface ATM0/0/0.1 point-to-point

no snmp trap link-status

pvc 0/32

pppoe-client dial-pool-number 1



interface Dialer1

description ADSL_WAN_Dialer

ip address negotiated

no ip redirects

no ip unreachables

no ip proxy-arp

ip mtu 1492

ip nbar protocol-discovery

ip nat outside

encapsulation ppp

ip tcp adjust-mss 1452

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname xxxxxxxxxxxxxx

ppp chap password 7 ssssssssssssss

ppp pap sent-username yyyyyyyyyyyyyyyyyy password 7 zzzzzzzzzzzzz

ppp ipcp route default




Thanks.

paolo bevilacqua Wed, 03/26/2008 - 05:29
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Can you send output of "show ver", "show diag", and "show dsl interface" ?

Pavel Bykov Wed, 03/26/2008 - 05:35
User Badges:
  • Silver, 250 points or more

I am also very much looking for a way to figure out the VPI/VCI on the ADSL line, without the use of an expensive tool that connects to telephone line in pass-through and reports the VPI/VCI flowing...


A special cisco debug would be very nice.


usslindstrom: 8/48 is popular in Europe, I heard 0/35 is popular as well. You are trying on 0/32?

usslindstrom Thu, 03/27/2008 - 04:58
User Badges:

Sh ver


Cisco IOS Software, 1841 Software (C1841-IPBASE-M), Version 12.4(17), RELEASE SO

FTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2007 by Cisco Systems, Inc.

Compiled Fri 07-Sep-07 14:45 by prod_rel_team


ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)


Oki_1841 uptime is 2 minutes

System returned to ROM by power-on

System restarted at 20:46:13 JST Thu Mar 27 2008

System image file is "flash:c1841-ipbase-mz.124-17.bin"


Cisco 1841 (revision 7.0) with 114688K/16384K bytes of memory.

Processor board ID FTX1146Z0EV

2 FastEthernet interfaces

1 ATM interface

DRAM configuration is 64 bits wide with parity disabled.

191K bytes of NVRAM.

31360K bytes of ATA CompactFlash (Read/Write)


Configuration register is 0x2102


---------------


sh diag



Slot 0:

C1841 2FE 2SLOT Mainboard Port adapter, 3 ports

Port adapter is analyzed

Port adapter insertion time 00:03:12 ago

EEPROM contents at hardware discovery:

Chassis MAC Address : 001e.1369.46e0

MAC Address block size : 34

PCB Serial Number : FOC114249XL

Hardware Revision : 7.0

Part Number : 73-8191-08

Board Revision : C0

Top Assy. Part Number : 800-23434-06

Deviation Number : 0

Fab Version : 04

CLEI Code : IPM7W00CRA

RMA Test History : 00

RMA Number : 0-0-0-0

RMA History : 00

Product (FRU) Number : CISCO1841

Version Identifier : V05

Processor type : 86

Chassis Serial Number : FTX1146Z0EV

EEPROM format version 4

EEPROM contents (hex


**Hex Omitted for maximum char limit**


WIC/HWIC Slot 0:

DSL SAR (ADSL)


Hardware Revision : 2.3

Part Number : 73-4771-08

Board Revision : B0

Deviation Number : 1-200

Fab Version : 05

PCB Serial Number : FOC072805EN

RMA Test History : 00

RMA Number : 0-0-0-0

RMA History : 00

Product (FRU) Number : WIC-1ADSL=

EEPROM format version 4

EEPROM contents (hex):

0x00: 04 FF 40 00 2E 41 02 03 82 49 12 A3 08 42 42 30

0x10: 80 00 01 00 C8 02 05 C1 8B 46 4F 43 30 37 32 38

0x20: 30 35 45 4E 03 00 81 00 00 00 00 04 00 FF FF FF

0x30: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

0x40: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

0x50: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF


---------------


sh dsl interface


ATM0/0/0

Alcatel 20150 chipset information

Line has not yet been activated. No information available.


DSL: Training log buffer capability is not enabled










Currently, I have the phone line unplugged from the Cisco router, as I'm using my old modem provided by the ISP.


*slidersv* - Yeah - I tried 0/35, like the ADSL config page here on Cisco's site suggested, but no go. You'd think that something like this could be auto-detected... Why is it, that a generic piece of crap router for $25 can, while a $1000 top of the line one can't?





Thanks so much for the assistance on this matter. Any ideas on why I can't connect with the Cisco router would be greatly appreciated.

paolo bevilacqua Thu, 03/27/2008 - 06:32
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

On the CRWS for the older 800 series routers, VCI/VPI autodetect was supported. Unfortunately that is not available for the 1841.


Please try 0/32.

Check:

http://www.ntt-west.co.jp/kiki/support/pdf/MN2_TORISETU.PDF

page 34.


(No I don't speak Japanese, but I'd like very much)


Hope this helps, please rate post if it does!

usslindstrom Thu, 03/27/2008 - 14:41
User Badges:

Yeah - tried 0/32 as well.


ADSL connection just stays in "initializing" on all counts.

paolo bevilacqua Thu, 03/27/2008 - 14:49
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Then it is not an VPI/VCI issue, yout line just doesn't synch.


Can you mention which exact IOS are you using, and the the exact adsl hardware as in "show diag".

paolo bevilacqua Thu, 03/27/2008 - 15:28
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Whoops I see that you posted the info already.

According to:

http://www.cisco.com/en/US/prod/collateral/routers/ps221/prod_bulletin0900aecd801d5c4c.html


you have already the latest adsl FW. Is your service adsl2 or adsl2+ by chance ? You would then need an hwic-1adsl instead of the older card you have now.

usslindstrom Thu, 03/27/2008 - 16:39
User Badges:

You might be on to something here. I aplogize for my confusion earlier, and thank you for your help, it's very much appreciated.


Getting any information from the ISP is sorta' like pulling teeth here in Japan. Most likely, because' of the communication gap, but that falls under "my fault" categories since I need to practice more.


For the ADSL2, that's probably what it is. The advertised download speed is 40Mb+... And it hadn't even crossed my mind before just now.


I'll grab one of the HWIC adsl modules and keep you posted on if that's the solution.


Thank you very much for helping.



paolo bevilacqua Fri, 03/28/2008 - 03:30
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Yes you've adsl2+ service and with the latest firmware I believe there is a 99.9% chance you'll be up and running with an hwic-1adsl.


Depending on what you need to do, even an 857, 877, or 1801 could do the job.


Good luck!


usslindstrom Sat, 05/24/2008 - 22:42
User Badges:

After a very extended transit time in the Mail... I finally got my HWIC module in.


The original IOS on the Router didn't have support for the module, and that was corrected by using c1841-adventerprisek9-mz.124-15.T3.


Unfortunately, I'm back at square 1 with everything.


On boot, the ATM interfaces (hardware and .1 point-to-point) both are stuck in "initializing". After a shut/no shut cycle on everything - their status changes to "Down" - and I can't get any further on it.





Any more ideas I can throw into the mix here would be greatly appreciated.

paolo bevilacqua Sun, 05/25/2008 - 03:10
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Please, send again "show dsl interfaces". I want to know which FW you've right now.

usslindstrom Sun, 05/25/2008 - 05:05
User Badges:

On a serious note - thank you so much for your assistance up to this point. It's very appreciated.


Here's a bunch of sh output's if you wouldn't mind tearin' em' apart for me. :)


**Sh Run**


interface ATM0/0/0

no ip address

no atm ilmi-keepalive

bundle-enable

dsl operating-mode auto

!

interface ATM0/0/0.1 point-to-point

pvc 0/32

pppoe-client dial-pool-number 1

!

!

interface Dialer1

description ADSL_WAN_Dialer

ip address negotiated

no ip redirects

no ip unreachables

no ip proxy-arp

ip mtu 1492

ip nbar protocol-discovery

ip nat outside

ip virtual-reassembly

encapsulation ppp

ip tcp adjust-mss 1452

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname xxxxxxxxx

ppp chap password 7 xxxxxxxxxxxxxx

ppp pap sent-username xxxxxxxxxxxxxx password 7 xxxxxxxxxxxxx

ppp ipcp route default


---------------


**Sh dsl interface**


ATM0/0/0

Alcatel 20190 chipset information


Line has not yet been activated.


Modem Status: Down (DMTDSL_DO_OPEN)

DSL Mode: Unknown

Interrupts: 16496 (0 spurious)

PHY Access Err: 0

Activations: 0

LED Status: OFF

LED On Time: 0

LED Off Time: 0

Init FW: init_AMR-3.0.014_no_bist.bin

Operation FW: AMR-3.0.014.bin

FW Source: embedded


DSL: Training log buffer capability is not enabled



---------------


**Sh Ver**


Cisco 1841 (revision 7.0) with 118784K/12288K bytes of memory.

Processor board ID FTX1146Z0EV

2 FastEthernet interfaces

1 ATM interface

1 Virtual Private Network (VPN) Module

DRAM configuration is 64 bits wide with parity disabled.

191K bytes of NVRAM.

253512K bytes of ATA CompactFlash (Read/Write)


**Sh IP Int Bri**


nterface IP-Address OK? Method Status Prot

ocol

FastEthernet0/0 unassigned YES NVRAM up down


FastEthernet0/1 unassigned YES NVRAM up down


ATM0/0/0 unassigned YES NVRAM initializing down


ATM0/0/0.1 unassigned YES unset initializing down


NVI0 unassigned NO unset up up


BVI1 192.168.1.1 YES NVRAM down down


Dialer1 unassigned YES NVRAM up up



---------------


**Sh Int Atm0/0/0**


ATM0/0/0 is initializing, line protocol is down

Hardware is HWIC-DSLSAR (with Alcatel ADSL Module)

MTU 4470 bytes, sub MTU 4470, BW 2048 Kbit, DLY 250 usec,

reliability 0/255, txload 1/255, rxload 1/255

Encapsulation ATM, loopback not set

Encapsulation(s): AAL5 AAL2, PVC mode

23 maximum active VCs, 256 VCs per VP, 0 current VCCs

VC Auto Creation Disabled.

VC idle disconnect time: 300 seconds

Last input never, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: Per VC Queueing

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

0 packets output, 0 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out



---------------


**Sh PPPOE session**


1 client session


Uniq ID PPPoE RemMAC Port VT VA State

SID LocMAC VA-st

N/A 0 0000.0000.0000 ATM0/0/0.1 Di1 N/A PADISNT

0000.0000.0000 VC: 0/32




paolo bevilacqua Sun, 05/25/2008 - 05:24
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

There's newer ADSL FW for you to try. If you have CCO download access:


ftp://:@ftp.cisco.com/cisco/access/800


use 3-0-39


If you do not have download access:

ftp://ftp.cisco.com/pub/access/800


use 3-0-33


In both cases there is a readme explaining installation. I know that you will let use know how it goes, good luck!

Edit: pls also configure "dsl mode itu adsl2+" or something like that, can't remember now exactly.

sirdudesly Sun, 05/25/2008 - 06:02
User Badges:

It might help us figure out what you need if you post


a) what modem your ISP supplied to connect to your current xDSL service

b) your isp name


That way we might have a better idea of what settings should be used

paolo bevilacqua Sun, 05/25/2008 - 06:32
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Sirdudesly, all the information you're asking for is in the thread if you take the time to read it.



sirdudesly Sun, 05/25/2008 - 13:56
User Badges:

ah yes, I see it now. I somehow missed expanding one of the messages.


The claimed 40mpbs speed mentioned before seems somewhat odd from an ADSL connection.

paolo bevilacqua Sun, 05/25/2008 - 14:33
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Good point, in fact Japanese 40 Mbps service is "ADSL PlusQ", that appers to be a domestic standard.


The hope is that there is compatibility with the HWIC albeit to a slower speed.

sirdudesly Sun, 05/25/2008 - 22:38
User Badges:

I've been looking around, I can't find much on PlusQ all I can gather is that it's pretty much the same as 'normal' ADSL2+ but for much shorter cable runs (i'd like to see it work here on my 6km+ adsl2+ run :P)

usslindstrom Tue, 11/25/2008 - 17:23
User Badges:

Well, after life getting in the way - and everything in between.


I tried to hammer out this problem again.


Unfortunately - I can't get the ADSL line to stop "initializing" - and I can't get the connection to stay up.


For this, I went ahead and dropped the ISPs ADSL modem into the mix, and went with a PPPoE config, using their equipment.


Everything came up almost instantaneously - however, the connection is EXTREMELY SLOW, and most sites time out entirely. Using the ISPs equipment, everything was pretty speedy, but as soon as the Cisco router is put into the mix, it's slower than crap.


I've played with the MTU settings, and even gone as low as 800, but nothing seems to affect it.


Here is the config, and some output commands:


Here are the router specs:

Cisco 1841 (revision 7.0) with 354304K/38912K bytes of memory

Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

flash: c1841-adventerprisek9-mz.124-15.T3.bin


Running Config:

interface FastEthernet0/1

description USS_WAN

no ip address

speed 100

full-duplex

pppoe enable group global

pppoe-client dial-pool-number 1

no cdp enable

interface Dialer1

ip address negotiated

ip mtu 1452

ip nat outside

ip virtual-reassembly

encapsulation ppp

ip tcp adjust-mss 1452

no ip mroute-cache

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname -----

ppp chap password -----

ppp pap sent-username ----- password -----

ppp ipcp route default


---------------


If anybody has any troubleshooting steps that I can take, I'd be in their debt.

Actions

This Discussion