copssh on CSM 3.1.1... cygwin problem?

Unanswered Question
Mar 25th, 2008

Hi folks!

After installed copssh (with the same cygwin1.dll version of ciscoworks), I had a restore backup problem, as explained in the restorebackup.log in attachment.

Now I have uninstalled the copssh software and I had erase all entry in the register key.

The restorebackup procedure give me this error:

ERROR: lib\classpath\com\cisco\nm\cmf\servlet\cwpass NOT present. Cannot find NMSROOT in archive

ERROR: Unable to delete directory C:\PROGRA~1\CSCOpx\tempBackupData in deleteDirectory()

Restore failed.

Anybody know if I have to clean something else?

Any helps would be appreciate!

Leonardo

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
Joe Clarke Tue, 03/25/2008 - 10:30

This sounds like the backup is bad. Was it taken with the other cygwin DLL or registry keys installed?

leorob123 Tue, 03/25/2008 - 11:20

thanks joe!

It was a corrupted DB.

I reinit all DB and now it running again.

Before copssh it was runnig correctly.

After install copssh, maybe the backup procedure didn't work propertly. The backuo use some cygwin1.dll command, right?

A question:

I need to syncronize the DB of two CSM 3.1 server.

How I can use the cw ssh services and the other CW cygwin tools, like tar and gzip in a a batch file?

Is it possible?

Thanks!

Leonardo

Joe Clarke Tue, 03/25/2008 - 11:22

The backup uses tar.exe which is linked to cygwin1.dll. If there is another cygwin1.dll or Cygwin mount registry keys set, this will interfere with the backup.

You cannot use other Cygwin apps on the same server as LMS. We have a few bugs opened on this, but there has been no resolution yet. If you need an SSH client/server, you will need to find one that does not use Cygwin. As far as a client goes, PuTTY is safe. I'm not sure on the server side, though.

amanolahi Mon, 07/14/2008 - 04:11

Hi,

we are running into the same issue with cygwin. LMs 3.0 and cygwin in the same server. During the restore process we got the same errors as you postet in your log file! Could you solved the problems? Is there any solution for this issue?

Kind Regrads

Naser

leorob123 Mon, 07/14/2008 - 04:21

Hi Naser,

the copssh, replace the CW cygwin1.dll with another into the CW server.

The CW tar.exe program, need to use the CW cygwin1.dll, then I had corrupted the backup files.

You have to unistall the copssh, and reinit the DB (all data will be lost).

Leonardo

amanolahi Mon, 07/14/2008 - 04:38

Hi Leonardo,

thanks for yor rapid responce. Do you think, if we reinit the DB, will there a way to make a restore?

Naser

Joe Clarke Mon, 07/14/2008 - 09:02

Cygwin problems should NEVER require any databases to be reinitialized. We just recommend one uninstalls all other Cygwin apps from the system, then the backup/restore will work as expected. The good news is we have removed Cygwin in LMS 3.1, so this should not longer be a problem.

amanolahi Tue, 07/15/2008 - 08:37

Thanks,

and this is the soluton which I'm looking for. A LMS without cygwin;-)

Regrads

Naser

Actions

This Discussion