FXO need to wait for dialtone

Unanswered Question

We are trying to use a single POTS line that is shared between a fax and an FXO port on a 2811 router. There is a line sharing device between the fax and the FXO that disconnects the fax and gives priority to the FXO when someone dials out. The issue is that the device takes about 3 seconds to disconnect, reset the line and then offer dialtone to the FXO port. By that time the port has gone off-hook, found no voltage or dialtone, and then goes back on hook all within 1 second and returns a fast busy to the caller. Is there any timing adjustments that can be made on the voice-port to allow the FXO to "wait" 3 to 4 seconds for dialtone before bailing out? I can't find anything that addresses this timeout setting.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
paolo bevilacqua Tue, 03/25/2008 - 12:01
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Can you try "pre-dial-delay" under voice-port ?


Another technique is "prefix ,,," under DP.

Some current must be flowing when fax now in use, else the line sharing device would not be able to detect "phone" going off-hook.

paolo bevilacqua Tue, 03/25/2008 - 12:27
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Likely you're getting:

htsp_process_event: [1/1/0, FXOLS_WAIT_DIAL_TONE, E_DSP_SIG_1100]fxols_power_denial_proc


It is not really about dialtone, but lack of sufficient voltage to make the router believe it is an actual live line. So I'm afraid that the device is actually incompatible with the router port.

Actions

This Discussion