As5300 dialing to ISP

Unanswered Question
Mar 25th, 2008

Hi,

I am trying to configure a AS5300 to dial to a ISP. I want to connect all the 120 modens with the ISP. I am trying to use GroupAsync and Dialer.

Is this the way, or how I can do this?

thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Makarand Chitale Wed, 03/26/2008 - 09:48

Let me understand the setup in more detail for 120 modems to dialout to an ISP:

1. Are they going to form a ppp multilink bundle?

2. Are they all going to dial one number (say a 800 number) or more than one number?

3. Do we want all the modems to call out at once or keep adding modems based on the load on the link?

4. Do we have a PRI (T1 or E1) or CAS signaling on these lines?

Thanks, Mak

guilherme.bedin Wed, 03/26/2008 - 10:11

1. Are they going to form a ppp multilink bundle?

If possible it will be good, but isn't a requirement.

2. Are they all going to dial one number (say a 800 number) or more than one number?

Yes, they all dial the same number.

3. Do we want all the modems to call out at once or keep adding modems based on the load on the link?

I want all modems call out at once and stay connected. If is possible program all modems to stay connected from 13h to 18h for example.

But if isn't possible to schedule the call out and hang-up, I will be happy to stay always connected with all modems.

4. Do we have a PRI (T1 or E1) or CAS signaling on these lines?

I have 4 E1 configured with:

controller E1 1

framing NO-CRC4

ds0-group 0 timeslots 1-15,17-31 type r2-digital r2-compelled ani

cas-custom 0

country brazil

metering

category 2

answer-signal group-b 1

Thanks for the help, let me known if you need more information.

Cheers,

Guilherme

Makarand Chitale Thu, 03/27/2008 - 11:30

The below sample configuration is for modems say in group-range 1 - 120, note they are bound to Dialer 1 using dialer pool commands. If we have discontinuous group of modems then we can create another group-asyn interface and bind to the same dialer 1 using dialer pool command.

interface Group-Async1

!--- Interface to configure modems used for dialout.

no ip address

encapsulation ppp

!--- Use PPP encapsulation for members of this

!--- group-async interface.

dialer in-band

!--- Permit DDR on this interface.

dialer pool-member 10

!--- All members of this group-async interface belong

!--- to dialer pool 10.

ppp multilink

!--- Enable PPP multilink on physical interface.

group-range 1 120

!--- Assign async 1-120 to this group-async interface.

!--- This can be adjusted depending on the number of POTS lines available.

!

interface Dialer1

!--- Dialer interface to dialout to ISP.

ip address negotiated

!--- Obtain an IP address from central site.

encapsulation ppp

dialer pool 10

!--- Defines the pool of physical resources that the Dialer

!--- interface may use.

dialer idle-timeout 600

!--- Specifies number of seconds without interesting traffic that

!--- the connection is kept up.

dialer string 8001234567

!--- Number to be dialed; this number belongs to the PRI

!--- of the central router.

dialer load-threshold 15 either

!--- Load level for either inbound or outbound traffic

!--- at which additional lines will be added to the MP bundle.

!--- Load level values range from 1 (unloaded) to 255 (fully loaded).

dialer-group 8

!--- Uses dialer-list 8 to determine interesting traffic.

ppp authentication chap callin

!--- Use CHAP authentication for incoming calls only

!--- This router will not challenge remote routers for outgoing calls.

ppp chap hostname xxxx

ppp chap password yyyy

! --- This is the chap hostname/password the ISP needs to see

! --- Can also use PAP

ppp multilink

!--- Activates the interface for MP operation.

ppp timeout multilink link remove 300

!--- Keeps the multilink connections up for 300 seconds

!--- after the load drops below the threshold.

!--- This command should be used to control flapping.

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!--- Use Interface Dialer1 for all networks.

!

dialer-list 8 protocol ip permit

line con 0

transport input none

line 1 120

modem InOut

transport preferred none

transport input all

Thanks, Mak

guilherme.bedin Fri, 03/28/2008 - 05:34

Hi Mak,

This is very close of what I have tried before. I tried this setup and still get the same problem as before, all the Async interfaces attached to the Dialer stay in Idle.

Like:

As1 - dialer type = IN-BAND ASYNC NO-PARITY

Dialer pool 10, priority 0

Idle timer (120 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is idle

How do I trigger something for them connect?

Do I need a chat-script in the line configuration? Like:

chat-script async "" "AT" OK "ATDT\T" TIMEOUT 30 CONNECT \c

Then, under your line 1, configure:

script connection async

modem dialout int async0/3/0

Thanks for the help.

Cheers,

Guilherme

Makarand Chitale Fri, 03/28/2008 - 07:54

Guilherme, dialer remaining idle means possibly no call is being made out. It needs interesting traffic to initiate a call, the commands used for the same are as follows:

dialer-group x binds with dialer-list x, dialer-list states what is interesting traffic - in the above configuration any ip traffic is interesting (dialer-list 8 protocol ip permit), we can always fine tune to say what is interesting traffic and what is not. Also we need a route for the interesting traffic to go out (ip route 0.0.0.0 0.0.0.0 dialer 1).

Ideally a ping to say 100.100.100.100 (any ip other than one assigned to an interface on the router) should initiate a call out.

No, we do not need to configure a chat script (IOS uses a default chat script if one is not configured).

Please enable the following debugs:

debug dialer / debug chat / debug modem / debug cas for a ping to say 100.100.100.100

Thanks, Mak

guilherme.bedin Mon, 03/31/2008 - 04:56

Mak,

Bellow is one of the configurations that I tried. Even doing the ping from the as5300

don't initiate any call-out.

About the debug, I am accessing the as5300 by telnet and I don't see any debug message even enabling the debugs that you asked.

controller E1 0

framing NO-CRC4

ds0-group 0 timeslots 1-15,17-31 type r2-digital r2-compelled ani

cas-custom 0

country brazil

metering

category 2

answer-signal group-b 1

!

controller E1 1

framing NO-CRC4

ds0-group 0 timeslots 1-15,17-31 type r2-digital r2-compelled ani

cas-custom 0

country brazil

metering

category 2

answer-signal group-b 1

!

controller E1 2

framing NO-CRC4

clock source line primary

ds0-group 0 timeslots 1-15,17-31 type r2-digital r2-compelled ani

cas-custom 0

country brazil

metering

category 2

answer-signal group-b 1

!

controller E1 3

framing NO-CRC4

ds0-group 0 timeslots 1-15,17-31 type r2-digital r2-compelled ani

cas-custom 0

country brazil

metering

category 2

answer-signal group-b 1

!

interface Ethernet0

no ip address

no ip route-cache

shutdown

no clns route-cache

!

interface Serial0

no ip address

no ip route-cache

shutdown

clockrate 2015232

no fair-queue

no clns route-cache

!

interface Serial1

no ip address

no ip route-cache

shutdown

clockrate 2015232

no fair-queue

no clns route-cache

!

interface Serial2

no ip address

no ip route-cache

shutdown

clockrate 2015232

no fair-queue

no clns route-cache

!

!

interface Serial3

no ip address

no ip route-cache

shutdown

clockrate 2015232

no fair-queue

no clns route-cache

!

interface FastEthernet0

ip address 192.168.100.1 255.255.255.0

no ip route-cache

duplex full

speed 100

no mop enabled

no clns route-cache

!

interface Group-Async1

no ip address

encapsulation ppp

dialer in-band

dialer pool-member 10

ppp multilink

no clns route-cache

group-range 1 120

!

interface Dialer1

ip address negotiated

encapsulation ppp

dialer pool 10

dialer idle-timeout 0

dialer string 0800000000

dialer load-threshold 1 outbound

dialer-group 8

ppp authentication chap callin

ppp chap hostname [email protected]

ppp chap password 0 ******

ppp multilink

ppp timeout multilink link remove 65535

no clns route-cache

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

!

!

dialer-list 8 protocol ip permit

!

!

snmp-server community public RO

!

!

!

!

!

line con 0

line 1 30

exec-timeout 0 0

modem InOut

modem autoconfigure type mica

modem dialout controller 0

rotary 1

transport preferred telnet

transport input all

transport output all

escape-character NONE

line 31 60

modem InOut

modem autoconfigure type mica

modem dialout controller 1

rotary 2

transport preferred telnet

transport input all

transport output all

escape-character NONE

line 61 90

modem InOut

modem autoconfigure type mica

modem dialout controller 2

rotary 3

transport input all

transport output all

escape-character NONE

line 91 120

modem InOut

modem autoconfigure type mica

modem dialout controller 3

rotary 4

transport input all

transport output all

escape-character NONE

line aux 0

line vty 0 4

password ******

login

Thanks,

Guilherme

Makarand Chitale Wed, 04/02/2008 - 15:29

Guilherme, when doing a telnet session you will need to type in "terminal monitor" to see the debug outputs (terminal no monitor to stop the outputs).

Make sure the controllers are up and up and the MICA modems ok, do a "show modem" output.

You can also initiate an test call using reverse telnet to a modem and calling out using atdt:

telnet 192.168.100.1 3001 ( this is : telnet <3000+rotary group number>)

type AT << this should return an OK

type ATDTxxxxxxx where xxxx is the phone number

Let's see if the ATDT test generates any debugs or not, if it does then try the ping test from the router prompt.

Thanks, Mak

guilherme.bedin Thu, 04/10/2008 - 05:57

Hi Mak,

Thanks for the tips, but still with the same problem. The show modem and reverse telenet works fine, I can connect with the ISP with tem and a linux machine with ttyredirector. The debug messages when I do this is:

*Apr 10 11:50:23.836: TTY1: asserting DTR

*Apr 10 11:50:26.324: from Trunk(0):

DMFC: Got sig@ u125674 c0 tone25 group3

*Apr 10 11:50:26.328: from Trunk(0): (0/25): Tx SEIZURE (ABCD=0001)

*Apr 10 11:50:26.360: from Trunk(0): (0/25): Rx SEIZURE_ACK (ABCD=1101)

*Apr 10 11:50:37.928: from Trunk(0): (0/25): Rx ANSWERED (ABCD=0101)

*Apr 10 11:50:54.088: TTY122: timer type 1 expired

*Apr 10 11:50:54.088: TTY122: Exec timer (continued)

*Apr 10 11:52:10.092: from Trunk(0): (0/25): Tx IDLE (ABCD=1001)

*Apr 10 11:52:10.128: from Trunk(0): (0/25): Rx IDLE (ABCD=1001)

*Apr 10 11:52:14.484: tcp1: conn not alive

*Apr 10 11:52:14.484: TTY1: no timer type 2 to destroy

*Apr 10 11:52:14.484: TTY1: Line reset by "TTY Daemon"

*Apr 10 11:52:14.484: TTY1: Modem: (unknown)->HANGUP

*Apr 10 11:52:14.484: TTY1: no timer type 0 to destroy

*Apr 10 11:52:14.484: TTY1: no timer type 1 to destroy

*Apr 10 11:52:14.484: TTY1: no timer type 3 to destroy

*Apr 10 11:52:14.484: TTY1: no timer type 4 to destroy

*Apr 10 11:52:14.484: TTY1: no timer type 10 to destroy

*Apr 10 11:52:14.484: TTY1: no timer type 2 to destroy

*Apr 10 11:52:15.092: TTY1: dropping DTR, hanging up

*Apr 10 11:52:15.092: tty1: Modem: HANGUP->IDLE

*Apr 10 11:52:16.604: %CALLRECORD-3-MODEM_CALL_REC_ERROR: DS0 slot/contr/chan=0/0/25, slot/port=1/0, call_id=8E58, userid=(n/a), ip=0.0.0.0, calling=(n/a), called=08000000, std=V.34+, prot=LAP-M, comp=V.42bis both, init-rx/tx b-rate=33600/33600, finl-rx/tx b-rate=33600/33600, rbs=0, d-pad=None, retr=0, sq=2, snr=39, rx/tx chars=806/736, p/w info=0, rx/tx ec=32/77, bad=0, time=91, finl-state=Steady, disc(radius)=none/No Reason, disc(modem)=8220 Rx (line to host) data flushing - OK/EC condition - locally detected/received DISC frame -- normal LAPM termi

*Apr 10 11:52:20.108: TTY1: restoring DTR

*Apr 10 11:52:21.108: TTY1: autoconfigure probe started

But with the dialer still nothing. The Group async and dialer configuration is:

interface Group-Async1

no ip address

encapsulation ppp

dialer in-band

dialer pool-member 10

ppp multilink

no clns route-cache

group-range 1 5

!

interface Dialer1

ip address negotiated

encapsulation ppp

dialer pool 10

dialer idle-timeout 0

dialer string 0800000

dialer load-threshold 1 outbound

dialer-group 8

ppp authentication chap callin

ppp chap hostname username

ppp chap password 0 xxxxxxx

ppp multilink

ppp timeout multilink link remove 65535

no clns route-cache

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

Don't appear anything in the debug messages even when I do a ping in 100.100.100.100. But the show dialers seems to be correct.

as5300#show dialer

As1 - dialer type = IN-BAND ASYNC NO-PARITY

Dialer pool 10, priority 0

Idle timer (120 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is idle

...

As5 - dialer type = IN-BAND ASYNC NO-PARITY

Dialer pool 10, priority 0

Idle timer (120 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is idle

Di1 - dialer type = DIALER PROFILE

Load threshold for dialing additional calls is 1

Idle timer (never), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is idle

Number of active calls = 0

Dial String Successes Failures Last DNIS Last status

0800000 0 0 never - Default

Gr1 - dialer type = IN-BAND ASYNC NO-PARITY

Idle timer (120 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is idle

Dial String Successes Failures Last DNIS Last status

Is there a way to force dialers to connect?

thanks for the help.

Guilherme

Actions

This Discussion