Using Different VLANs within a MPLS VRF

Unanswered Question
Mar 26th, 2008

Hi,

My company has a couple of clients that have similar network requirements that need to transverse our IP/MPLS core. We are looking at the possibility of grouping these clients within the same VRF and use VLANs to separate their traffic.

I would need advice on the best possible way to achieve this.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
royalblues Wed, 03/26/2008 - 05:44

If you need to group your clients into a single VRF, all you need to do is to just define the VRF on the PE under the interface towards the CE.

Vlans can be defined on the switch as you would do in a normal campus network.

If you need to have seperation throughout, you can use vrf lite at the campus and use different vrfs for each client

Narayan

Harold Ritter Sat, 03/29/2008 - 06:05

Olubunmi,

Bear in mind that even if these customers are on different vlans, they will still have access to each others network at layer 3 as they will be terminating in the same VRF. Probably not something you want.

Regards,

shivlu jain Sat, 03/29/2008 - 08:30

ip vrf abc

rd 1:1

rt both 1:1

interface GigabitEthernet0/3.204

encapsulation dot1Q 204

ip vrf forwarding abc

ip address 10.16.170.69 255.255.255.252

end

interface GigabitEthernet0/3.205

encapsulation dot1Q 204

ip vrf forwarding abc

ip address 10.16.170.69 255.255.255.252

end

regards

shivlu

Actions

This Discussion