Time controlled Bandwidth

Unanswered Question
Mar 26th, 2008

I want to shape traffic on a Catalyst 3550 (IOS 12.1(20)EA1) port so that during the day, the bandwidth will be 10Mbps, and at 7pm, the bandwidth changes to 100Mbps. Essentially 7am-7pm (10Mbps) and 7pm- 7am (100Mbps). Client is performing backups at night and requires the extra bandwidth.

Here is my config.

mls qos aggregate-policer BUS_HOURS-IN 10240000 64000 exceed-action drop

class-map match-any BUS_HOURS-IN

match access-group name BUS_HOURS-IN

policy-map BUS_HOURS-IN

class BUS_HOURS-IN

police aggregate BUS_HOURS-IN set ip dscp 0

ip access-list extended BUS_HOURS-IN

permit ip any any time-range INTERNET-0700_TO_1900_HOURS

#sh run int fa0/7….” (EGRESS PORT)”

interface FastEthernet0/7

switchport access vlan x

switchport mode access

switchport nonegotiate

speed 100

duplex full

service-policy input BUS_HOURS-IN

mls qos monitor dscp 0 8 16 32 40 46 48 63

service-policy history

wrr-queue bandwidth 10 20 30 40

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4 6 7

wrr-queue cos-map 4 5

priority-queue out

random-detect

no cdp enable

spanning-tree portfast

spanning-tree bpdufilter enable

The strange thing is that when I apply the policy to the interface, the bandwidth is throttled down to 3Mbps between 7pm-7am.????

I've asked the client to check their next hop interfaces on both ends of this circuit and it's set to 100Mbps Full duplex.

When I remove the policy, their bandwidth peaks at 60Mbps.

Is my config missing something?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
darrenj Wed, 03/26/2008 - 08:24

Hmmm, this is interesting. A few quick observations. First of all, the time-range config is not shown (it would be good to validate this) and secondly, you mention shaping initially but you are actually policing (shaping and policing are different).

Additionally, you are only implementing policing inbound, therefore traffic can travel outbound unrestricted - is this what you want?

I would consider shaping (outbound direction) on either end of the link, you may get better results with the buffering that this does. Also, for clarity I would use two class-maps, one for 7am-7pm restricted to 10mbps and one for 7pm-7am restricted to 100mbps - gives you a much clearer idea of what is going on.

Hope this helps

Darren Johnson

CCIE#20078

Actions

This Discussion