WAN switching

Answered Question
Mar 26th, 2008

Hi i have gateway 2811 and 2 internet provider. As i can make, when 1 provider disconect internet automatic switching on port 2 provider. And when connect with 1 provider resume internet switching on port 1 provider.

I have this problem too.
0 votes
Correct Answer by Giuseppe Larosa about 8 years 6 months ago

Hello sun,

if you want to use PBR = policy based routing you need to apply it on the inside interface.

In fact, with your configuration you are checking if the source address is in the server address block or if it is in the user block.

Move the command ip policy route-map univer command under the inside interface

hope to help

Giuseppe

Correct Answer by Paolo Bevilacqua about 8 years 8 months ago

Begin with two static routes (one can have an better metric if you do not want load-balancing)

) and two nat statements. Once you are in the situation where you can shutdown either interface, clear nat translations, and things continue to work, you go for the second part (ip sla).

The initial example is:

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_configuration_example09186a0080950834.shtml

the advanced one is:

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_configuration_example09186a00808d2b72.shtml

Good luck!

Hope this helps, please rate post if it does!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
Paolo Bevilacqua Wed, 03/26/2008 - 07:34

That is not an easy configuration. Do you have enough expereince to read and interpret examples and adapt them to your needs ?

sun_sazanov Wed, 03/26/2008 - 08:45

yes. I think that I would have enough experience what to adapt examples under the requirements

Correct Answer
Paolo Bevilacqua Wed, 03/26/2008 - 09:39

Begin with two static routes (one can have an better metric if you do not want load-balancing)

) and two nat statements. Once you are in the situation where you can shutdown either interface, clear nat translations, and things continue to work, you go for the second part (ip sla).

The initial example is:

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_configuration_example09186a0080950834.shtml

the advanced one is:

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_configuration_example09186a00808d2b72.shtml

Good luck!

Hope this helps, please rate post if it does!

sun_sazanov Fri, 05/16/2008 - 01:08

Hi.

I want for user 10.10.10.0/24 goto internet over 1 isp, 10.10.11.0/24 over 2 isp.

I have next configuration.

!

interface GigabitEthernet0/1.1

description $ETH-LAN$

encapsulation dot1Q 102

ip address 92.255.X.XXX 255.255.255.252

ip access-group sdm_gigabitethernet0/1.1_in in

ip nat outside

ip inspect SDM_LOW out

ip virtual-reassembly

ip policy route-map sety

!

interface GigabitEthernet0/1.2

description $ETH-LAN$

encapsulation dot1Q 101

ip address 195.70.X.XXX 255.255.255.240

ip access-group 142 in

ip nat outside

ip inspect SDM_LOW out

ip virtual-reassembly

ip policy route-map univer

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 195.70.X.YYY

ip route 0.0.0.0 0.0.0.0 92.255.X.YYY

!

ip nat inside source route-map sety interface GigabitEthernet0/1.1 overload

ip nat inside source route-map univer interface GigabitEthernet0/1.2 overload

!

ip access-list standard Serv

remark Nat for server

remark SDM_ACL Category=2

permit 10.10.10.0 0.0.0.255

ip access-list standard User

remark SDM_ACL Category=2

permit 10.10.11.0 0.0.0.255

!

!

route-map univer permit 10

match ip address Serv

set ip next-hop 195.70.X.YYY

!

route-map sety permit 10

match ip address User

set ip next-hop 92.255.X.YYY

!

!

But this configuration, not work. You can help me with this problemm.

Correct Answer
Giuseppe Larosa Fri, 05/16/2008 - 01:47

Hello sun,

if you want to use PBR = policy based routing you need to apply it on the inside interface.

In fact, with your configuration you are checking if the source address is in the server address block or if it is in the user block.

Move the command ip policy route-map univer command under the inside interface

hope to help

Giuseppe

sun_sazanov Tue, 05/20/2008 - 00:14

Hi.

In my network work next sheme.

traffic network 10.10.10.0/24 and 10.10.11.0/24 collect on 3750 and goto on 2821 with ip 10.10.4.1 and goto internet.

And if i move commad ip policy route map univer under interface with ip 10.10.4.1 it's not work.

As still it is possible to make distribution of the traffic between ISP? for network 10.10.10.0 --> ISP1 and network 10.10.11.0 --> ISP2

Actions

This Discussion