SSL VPN Client Error Message

Unanswered Question
Mar 26th, 2008
User Badges:

I am using ASA5520 as my SSL VPN for remote users. One user got an error message "The SSL VPN Client driver has encountered an error" The user has already rebooted her laptop but still got the same error message. What is the best way to rectify this problem.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
santipongv Wed, 03/26/2008 - 14:31
User Badges:

This problem has been rectified. User ID was assigned to the wrong group.

neibergerj Mon, 08/18/2008 - 06:51
User Badges:

Can you clarify what you did to resolve this? We're having the same problem.


Thanks!

santipongv Mon, 08/18/2008 - 06:55
User Badges:

I had user uninstall VPN client and logged back in. This resolved the problem.

neibergerj Mon, 08/18/2008 - 07:00
User Badges:

Darn. We've tried that and we're still getting that error. It's frustrating because it's very difficult to find information about this error.

ggilbert Mon, 08/18/2008 - 08:23
User Badges:
  • Cisco Employee,

Can you clean up the Event log viewer on the end users PC and try to launch the client again.


See if there are any errors/informational messages. If so, can you please cut and paste them in this Discussion forum.


What is the version of code you are running on your ASA?


What is the version of code you are using for the SSL VPN Client?


Does the user have Administrative privileges on the machine?


Thanks

Gilbert

neibergerj Mon, 08/18/2008 - 14:36
User Badges:

I'll have our systems guy look at the event logs next time he's out there. I don't know if that's something he has already checked or not. I'll post anything I find.


We're running 8.0(2) on the ASA. This is going to sound dumb, but how do I determine the level of code being used for SSL VPN? I'm fairly new to the ASA.


The end users do not have admin privileges, but the system guy who is trying to get this to work does have admin privileges.


Thanks!

ggilbert Tue, 08/19/2008 - 06:46
User Badges:
  • Cisco Employee,

Hello,


You can do "sh run | in ssl" and the running configuration should have the sslvpn client information you are using.


or you can do "sh flash" which will let you know the version of ssl client that is on the ASA.


Inorder for SSL VPN to work, it installs a Virtual Adapter on the machine. So, admin privileges are needed for the Virtual adapter to be installed.


Hope this helps.


Thanks

Gilbert



neibergerj Tue, 08/19/2008 - 09:03
User Badges:

Here is the output from show flash:


--#-- --length-- -----date/time------ path

41 7496664 May 17 2006 06:48:38 asdm512-1.bin

42 6889764 Dec 03 2007 11:57:54 asdm-602.bin

44 10198 Mar 02 2006 14:27:50 logo.jpg

45 5539756 Jan 02 2007 10:45:26 asdm521.bin

46 415090 Oct 05 2006 08:25:32 sslclient-win-1.1.2.169.pkg

47 4096 Dec 04 2007 05:52:51 sdesktop

71 1968 Dec 04 2007 13:06:12 sdesktop/data.xml

58 6734 Aug 13 2007 17:29:20 sdesktop/data.bak

2 4096 Dec 03 2007 15:37:44 log

48 5623108 Dec 11 2006 13:33:56 asdm-522.bin

49 3717 Aug 16 2006 14:19:02 Home_banner.gif

50 1789952 Dec 03 2007 13:20:06 anyconnect-win-2.0.0343-k9.msi

51 8312832 Jan 16 2007 12:28:14 asa722-k8.bin

52 14524416 Dec 03 2007 11:44:30 asa802-k8.bin

53 3219872 Dec 03 2007 12:35:12 securedesktop-asa-3.2.0.136-k9.pkg

54 2635734 Dec 03 2007 13:22:08 anyconnect-win-2.0.0343-k9.pkg

6 4096 Dec 03 2007 15:38:08 crypto_archive



The person installing the software on the PC is an administrator, so this shouldn't be a privilege issue unless he is doing it while logged in as the user. I'll ask him and find out exactly how he was doing it.

ggilbert Tue, 08/19/2008 - 10:47
User Badges:
  • Cisco Employee,

If you running 8.0.2 version of code on the ASA. Then you should be using the "anyconnect client". Why are you using the SSL VPN Client?


If the user is trying to install the SSL VPN client and you are using 8.0.2, please make sure that ASA points to the right client information.


And ask the end user to install the Anyconnect client on the PC.


Thanks

Gilbert

neibergerj Tue, 08/19/2008 - 10:58
User Badges:

I just checked with him. He is installing anyconnect-win-2.1.0148-pre-deploy-k9.msi as administrator.

Actions

This Discussion