Unity 5.01 odd TUI problem

Unanswered Question
Mar 26th, 2008

All,

I have an odd TUI issue with 5.01.

Setup: Two 7845 servers running Unity Unified Communications 5.01 in a failover configuration. Partner Exchange server is MS Exchange 2003 SP2

Problem: I have several users who cannot send messages via the TUI but can send messages via the VMO in Outlook. Secure messaging is enabled but doesn't seem to be the issue as when we disable it the same problem still exists. There are other users who can send voicemails via the TUI interface to anyone so the problem is not consistent.

We've tried removing the troubled users from Unity and reimporting them to no avail.

We've tried removing a troubled user from Unity, deleting their MS Exchange mailbox (we were allowed to do this on one deprecated account) and then recreate/re-import into Unity and still the problem exists.

We've tried running the permissions wizard again. We've tried re-partnering with the MS Exchange server again. We've even rebooted both Unity boxes, to no avail.

When the problem occurs the following events get logged into the Windows eventlog:

Event Type: Error

Event Source: CiscoUnity_ConvMsg

Event Category: (9)

Event ID: 10001

Date: 3/26/2008

Time: 12:10:28 PM

User: N/A

Computer: US-VO-SAC001

Description:

Running conversation SubMenu on Port 1

Running conversation StreamlinedSend on Port 1

Running conversation StreamlinedSendMenu on Port 1

Event Type: Error

Event Source: CiscoUnity_ConvMsg

Event Category: Network

Event ID: 10015

Date: 3/26/2008

Time: 12:10:28 PM

User: N/A

Computer: US-VO-SAC001

Description:

IAvDohMessage::Submit returned [0x800404dc] on line 1002 of file H:\views\CUESB1_view\un_Core2\ConversationEng\AvStateSvr\AvSMsgSend.cpp

Event Type: Error

Event Source: CiscoUnity_ConvMsg

Event Category: (9)

Event ID: 10001

Date: 3/26/2008

Time: 12:10:28 PM

User: N/A

Computer: US-VO-SAC001

Running conversation SubMenu on Port 1

Running conversation StreamlinedSend on Port 1

Running conversation StreamlinedSendMenu on Port 1

Event Type: Error

Event Source: CiscoUnity_ConvMsg

Event Category: Network

Event ID: 10015

Date: 3/26/2008

Time: 12:10:28 PM

User: N/A

Computer: US-VO-SAC001

Description:

IAvDohMessage::Submit returned [0x800404dc] on line 995 of file H:\views\CUESB1_view\un_Core2\ConversationEng\AvStateSvr\AvSMsgSend.cpp

Event Type: Error

Event Source: CiscoUnity_ConvMsg

Event Category: (9)

Event ID: 10001

Date: 3/26/2008

Time: 12:10:28 PM

User: N/A

Computer: US-VO-SAC001

Description:

Running conversation SubSignIn on Port 1

Running conversation SubAuthenticate on Port 1

Any help would be appreciated as I am stumped here.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Steven Griffin Thu, 03/27/2008 - 07:59

Well I solved my own problem. Turns out those several users were members of some special groups. When that happens Windows disables inheritance of permissions on the AD account automatically. Removing the users from the groups and enabling inherit permissions again fixed the issue.

FYI, from Microsoft's website:

http://support.microsoft.com/kb/817433/en-us

The following list describes the protected groups in Windows 2000: • Enterprise Admins

• Schema Admins

• Domain Admins

• Administrators

The following list describes the protected groups in Windows Server 2003 and in Windows 2000 after you apply the 327825 hotfix or you install Windows 2000 Service Pack 4: • Administrators

• Account Operators

• Server Operators

• Print Operators

• Backup Operators

• Domain Admins

• Schema Admins

• Enterprise Admins

• Cert Publishers

Additionally the following users are also considered protected: • Administrator

• Krbtgt

Actions

This Discussion