subscriber server not available for some phones in the same device pool

Unanswered Question
Mar 27th, 2008


This is CUCM 6.1(1)a. I have 7941 phones that are all configured for the same device pool. They are configured to register to the subscriber and the publisher is configured in DHCP to be the primary TFTP server. When we originally set up the servers and a couple of test phones, we manually assigned the IP address, gateway, TFTP server, etc by unlocking the network settings. Later, DHCP was re-enabled on the phones and they worked fine. Now we are setting up a few more IP Phones, and they are on the same vlan as the other working phones. They get a DHCP IP address from the same vlan as the other phones. In fact all the settings are the same except for the callmanager settings. Instead of CallManager 1 as (active) and CallManager 2 as, the phones show CallManager 1 as CISCO-BCD0B887D and CallManager 2 as (active). Although the phones can dial out, the problem is when they press the services button and it says Host Not Found. The server name listed is not even the actual hostname of the server. Does anyone have any ideas on how to fix this? I even tried to create a new device pool that listed only subscriber server as the only server in the cm group and the phones still register only to the publisher.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
steven.lass Fri, 03/28/2008 - 06:44

I think you may have a hostname/DNS issue. You can put the hostname into DNS, but we typically setup everything to use IP so that DNS outages will not affect the system.

Check System/Server on CM and use IP addresses instead of hostnames. This should correct the phone Call Manager settings.

To fix the phone services button, go to System/Enterprise Parameters and change the Phone URLs from hostnames to IP addresses.


vivian.le Fri, 03/28/2008 - 07:54

Sorry Steve. I should have given more detail. System > Server settings have always been configured with IP addresses. In fact, everything is setup to use IP addresses. That's why I'm puzzled as to why a hostname is even listed. Even so, the hostname that appears in the phone configuration isn't the actual hostname of the server.

pklos Fri, 03/28/2008 - 08:01

Were the phone added via BAT? If yes I had similar issue, solution for this is opening each phone configuration, clicking Save without any changes and resetting phone.




vivian.le Fri, 03/28/2008 - 08:27

The phone was loaded via BAT. I went to the device page and reset the phone, but no go, it still has the same problem. Also tried to manually configure the network settings on the phone. Even when the IP Address for the subscriber is entered in as the CallManager 1 address, it still comes up with that strange hostname.

vivian.le Tue, 07/28/2009 - 11:56

I don't remember what the exact fix was for my scenario, but it was network related. Check your vlan and DHCP configurations.


This Discussion