LMS 3.0 troubleshooting

Unanswered Question
Mar 28th, 2008


I was wondering if anyone else has had the following problem when trying the task of clicking "Device Troubleshooting" under Device Center. I get the following error

CWA025: Could not launch the workflow.

CWA engine may not be running.

Restart the daemon manager of the server:On Windows: 1. Enter net stop crmdmgtd 2. Enter net start crmdmgtd On Solaris: 1. Enter /etc/init.d/dmgtd stop 2. Enter /etc/init.d/dmgtd start If the problem persists, contact the CiscoWorks server administrator.

I have tried restarting this service but to no avail. I also am unable to query my device's to get an Inventory Update, after several hours I get a timeout error. I can use CiscoView successfully so my SNMP settings are correct. Any ideas ?



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (3 ratings)
Joe Clarke Fri, 03/28/2008 - 22:29

Try reinitializing the opsxml database with the following command:

NMSROOT\bin\perl NMSROOT\bin\dbRestoreOrig.pl dsn=opsxml dmprefix=Opsxml npwd=cisco

Then see if you're able to start the workflow.

duncalsi75 Sun, 03/30/2008 - 16:51

Hi, have tried this and still encountering the same issue. Have you got any other ideas as to why the workflow is not starting ?


Joe Clarke Sun, 03/30/2008 - 16:59

Enable CWA debugging under CWA > Admin > Log Level Settings. Then reproduce the problem, and post the CWA.log and the NMSROOT\objects\wfengine\Program\OpsXml.log and Datastore.log.

duncalsi75 Sun, 03/30/2008 - 17:19

The opsXML file is dated 25th march, so there are no entries, the last is

OpsXML Server Starting at Tue Mar 25 15:54:52 2008

Datastore.log again the last entry is the 25th March

DataStore Exited @ Tue Mar 25 15:28:02 2008

DataStore Started @ Tue Mar 25 15:34:03 2008

DataStore Exited @ Tue Mar 25 15:49:29 2008

DataStore Started @ Tue Mar 25 15:54:59 2008

I have checked the server has the correct date and time

duncalsi75 Sun, 03/30/2008 - 20:30

Sorry do you want me to do a

net stop crmdmgtd

and then do a pdshow again ?

Joe Clarke Sun, 03/30/2008 - 20:38

No, I want you to do a net stop crmdmgtd, then send me the list of all processes running on the server. Pdshow will not work with dmgtd shutdown, but I care about Windows processes at this point.

Joe Clarke Sun, 03/30/2008 - 22:29

Interestingly enough, one of my Windows servers was exhibiting the same problem. It turns out my wfengine processes had died, but pdshow reported OpsXMLRuntime was still running. Restarting OpsXMLRuntime fixed it for me. Restart dmgtd, and see if the workflow starts to work. If not, post a new process list and pdshow output now that dmgtd is running.

Joe Clarke Sun, 03/30/2008 - 23:13

All of the necessary processes are running. With CWA and CWA engine debuggign still enabled, are there any new updates in the DataStore.log and OpsXML.log?

duncalsi75 Mon, 03/31/2008 - 17:24

Thankyou, that was the problem with Workflow, which is now working However I assumed this problem with workflow was the reason that I was unable to successfully able to complete a Inventory Update of a device. I have again tried to update the inventory and after several hours the job times out. I receive the message "Timed out. Make sure that ICServer is running" under the Job Results Description. I can use CiscoView to view the device, so I know SNMP is working correctly. Thanks

Joe Clarke Tue, 04/01/2008 - 10:04

I assume device is your problem device. If that is the case, it appears there is an SNMP credential issue with this device in DCR. Other than that, I don't see any errors.

duncalsi75 Wed, 04/02/2008 - 22:22

On closer inspection it appears none of my devices are having the "Update Inventory" function work. This is my Devl test area and need to prove it working before rolling into Prod

Joe Clarke Fri, 04/04/2008 - 11:04

Enable ICServer Inventory collection and job debugging under RME > Admin > System Preferences > Loglevel Settings, then run another inventory job. Post the new IC_Server.log as well as the log from the job directory under NMSROOT\files\rme\jobs\ICServer.

Joe Clarke Sat, 04/05/2008 - 09:30

Something appears to be deadlocking ICServer. But I can't see what that is since debugging was not enabled when it happened. It won't respond to any requests again until you restart it.

So, restart ICServer with "pdterm ICServer" followed by "pdexec ICServer". Then, keep debugging on, and run jobs until the job times out. Then post the new IC_Server.log.

If the problem still cannot be ascertained, you will need to open a service request with TAC so that ICServer can be run manually so a full thread dump can be captured.

Joe Clarke Sun, 04/06/2008 - 07:40

I don't see what could be causing the deadlock. Please post ICServer.log.

Joe Clarke Sun, 04/06/2008 - 19:54

This explains why inventory is not working, but I'm not sure how this could have happened. It looks like your installation failed or was corrupted. At least two key files are damaged. Since it doesn't sound like this ever worked, I recommend you uninstall LMS, then reinstall it from scratch.

duncalsi75 Sun, 04/06/2008 - 20:02

I upgraded from LMS 2.6 to 3.0. Should I revert back to the snapshot and try again or are you saying version 2.6 never worked ?

Joe Clarke Sun, 04/06/2008 - 20:19

Well, it looks like you're on VMWare, and LMS 2.6 was never supported on VMWare, so there's no way to gage.

The best course of action would be to install LMS 3.0 from scratch on your VMWare image, then immediately upgrade to 3.0.1 (as 3.0.1 is the only version supported on VMWare).


This Discussion