Display forwarding extension on CFwdAll

Unanswered Question
Mar 28th, 2008

I activated CFwdAll on my extension to forward all calls to my mobile. When I receive the call on my mobile I always see the main number of the line as caller ID if an external user is calling my extension. I know it is because the callmanager is sending the original number as caller id and ptt does not accept this. How can I make the callmanager send my extension as caller id.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
mattcalderon Fri, 03/28/2008 - 08:09

I would make a route pattern explicitly for your mobile and then under that route pattern change the calling number mask to your DID. See if that helps at all. This would be a quick fix, but I am not sure if there is a more "appropriate way"

metuzuner Fri, 03/28/2008 - 08:46

Hi Evan,

Let us know if you can get this accomplished. I tried Matt's fix above and it does not work; still shows billing #. Also, as far as I know, telco should have the ability to implement RNDIS (not sure about the acronym) that'd allow sending the forwarded call's caller ID properly.



brandoncheah Wed, 05/14/2008 - 07:28

I would check the number on your gateways under caller id dn if you are running call manager. No matter how much you try to manipulate the digits, if the caller id dn is set to a certain number, it will always display that number no matter what.

I would check that and see what that is set to. If you erase the caller id dn on the gateway and you forward your calls to your mobile, your extension will show up on your caller id or whatever mask you set for your ext.

alig.norbert Thu, 05/15/2008 - 10:32

I have the same issue on our CM.

Is the "special arrangement" (routing must be done from the CM) from the PSTN-Provider activated?

mciarfello Sat, 05/17/2008 - 21:25

What do you get when your IP Phone dials your mobile phone directly?

In the route pattern that gets selected to call your mobile phone, what are the settings under "calling party transformations"


In your route list details, what is the setting for "Use Calling Party's external phone number mask?

If there a "calling party transform mask" defined on that page?


If either the above are using external phone mask (default or ON), what is the External Phone Mask of your IP Phone's Directory number set to.

Next (I'm doing these in a specific order here from most granular to least granular.) What is the setting on the gateway Caller ID DN?(already discussed.) Should be blank.

last, is the telco honoring your ANI or just replacing everything with the billing telephoe number?

The ExternPhoneMAsk on the Line is the most granular but I had to discuss the route list and route pattern first. Use ExternMask not turned on then that setting doesn't matter.

sohaildxbfze Sat, 05/17/2008 - 23:45


take following steps

1. Under CM Menu Gateway>Calling Line ID Presentation Select Allowed AND Calling Party Selection Select "Last Redirect Number(External)

2.Under Route Pattern Menu>Calling Party Transformations

Use Calling Party's External Phone Number Mask

3. apply DN as external mask for the line

4.restart your gateway

If it helps rate the post


This Discussion