Switchport trunks on end devices/ switchport trunk native.

Unanswered Question
Mar 28th, 2008

All, I have this config I inherited: To me, this config looks out of wack. These ports are end user ports for some machines we have on the shop floor. Their are no phone attached to the ports configured as below. I do plan on removing the qos, and srr-queue commands. My question is, what is the point of the switchport trunk commands? Are end user ports to be trunked?

What does the Switchport trunk native, do for me?

VLAN 205 is a bogus VLAN. Is it needed?


interface FastEthernet1/0/3

switchport access vlan 200

switchport trunk encapsulation dot1q

switchport trunk native vlan 205

switchport mode dynamic desirable

switchport voice vlan 246

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
ankbhasi Fri, 03/28/2008 - 10:10

Hi Friend,

You can remove all trunk related commands if you are sure this ports if for end user host. Also change "switchport mode dynamic desirable" to "switchport mode access".

Sometimes even when servers are connected on switchport they understand dot1q tags and is the reason switchport may be configured for trunk but as you mentioned they are user ports you can simply remove trunk configuration.



*Pls rate all helpfull post

padramas Fri, 03/28/2008 - 10:39

Hello Rob,

As you have mentioned the role of the ports and devices connected to it, the above configuration can be stripped down to basic configuration.

interface FastEthernet1/0/3

switchport access vlan XX

spanning-tree portfast


Regarding your questions on switchport trunk,

a port has to be configured as trunk when it has to carry multiple vlan traffic and to differentiate traffic we define encapsulation method.

Trunk native is used to identify the vlan traffic for which frames will not be tagged/encapsulated.




This Discussion