dhcp and routing problem

Unanswered Question
Mar 30th, 2008

Hi,

I use Cisco 850 router as DHCP server. When I set IP address in some client PC manually I can't access the router (no response to ping, no response to telnet session, etc.), when address is set via DHCP, router responses. The same behavior is when I try to ping some client from router. Ping packets are sent only when pinging clients with IP addresses assigned by DHCP. If I ping clients with static address no ping packets are sent from router. I am new to Cisco IOS so I can't find what is wrong. I think routers configuration is incomplete. I tried to play with routing but no effect. Please helppp...

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
knudsen-s Sun, 03/30/2008 - 12:42

Hi,

First i can se that this is a probem, but after i have looked at your config I have one question to you.

What are yu trying to acomplish ?

You have loopback that is both used at a vpdn and vlan 1 ?

If you tell what you realy whant this router to do there might be a better and simpler config ??

/Soren

Richard Burts Sun, 03/30/2008 - 15:35

Algirdas

The symptoms that you describe are pretty unusual and I believe that we will need some additional information to be able to identify the source of the problem. Can you give us some specifics of how you manually configure the client when there is a problem: in particular I would like to know to what is the client connected, what IP address is assigned, what subnet mask is assigned, and what default gateway is assigned? Is there any possibility that the IP address that you are manually assigning is also assigned to some other PC by DHCP?

I note in the config that you have DHCP excluded addresses in 192.168.6 but I do not see 192.168.6 being used in this config. Can you explain to us what is being used for 192.168.6?

HTH

Rick

Algirdasss Mon, 03/31/2008 - 00:21

rburts

these lines

ip dhcp excluded-address 192.168.6.1 192.168.6.9

ip dhcp excluded-address 192.168.6.21 192.168.6.254

are carp left from earlier config (I used for testing in my office). These lines don't mean anything. I use network 192.168.0.0 only. Addresses in range 192.168.0.1 - 192.168.0.199 are for clients with static IP addresses (must be so). About static addresses:

1. Client are computers with Win XP and various industrial equipment (ABB, Beckhoff controllers)

2. As I mentioned they are assignet manual IP addresses from range 192.168.0.0 - 192.168.0.199

3. Subnet masks are 255.255.255.0

4. No gateway is assignet because these devices are allowed to operate only in local network

5. No IP address overlaping. In testing phase we have only several devices with clearly defined static IP addresses. No DHCP clients.

Algirdasss Mon, 03/31/2008 - 00:10

It's a gateway rooter with IPSec VPN and NAT capabilities. Why I used Loopback... first when I unnumbered VirtualTemplate directly to Vlan I had problems connecting to router via VPN when Vlan interface was down (when no devices where connected to FastEthernet ports). I already wrote about this problem in Cisco forums earlier. So I used Loopback both for vlan and virtualtemplate because it's always up. Also I want all clients (either they connect via VPN or directly to FastEthernet) to reside in one lan subnet (so not only IP packets could travel between them). Clients I split into two groups: with static IP addresses (must be static!!!) and dinamically assigned addresses.

If you see any possibilities of better configuratio ofcourse I'd like to know about it:)

knudsen-s Mon, 03/31/2008 - 00:33

HI,

Thanx for the info.

No I have not made that config before when it is lan and vpn , but i cannot see why it should not work.

One thing that you need to check and can be the problem:

When the router deliver a dhcp ip it knows where it is located (via VLAN 1 or VPN), when you use static it do not have this info.

PLs. check where is sends the packet ?

Try to disable ip cef so you do process switching, be aware that this will slow the router down a bit. :-)

/soren

Actions

This Discussion