How to get out of Rommon

Unanswered Question
Mar 30th, 2008

Hello All,

I mistakenly started an xmodem procedure on a wrong router, though no ios has been downloaded before i realized.

Now i want to get out of rommon mode and preserve the current configuration but don't know how to get out of rommon.

Even when the baud rate was changed to 9600 N 8 1 from 115200, it still don't work.

Somebody please help me out.

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Sun, 03/30/2008 - 18:54

Your post is a bit ambiguous about how far the xmodem procedure has gotten. You say that it has not yet downloaded an IOS image but does not tell us whether it has yet erased the existing image to prepare for the download. If it has not yet erased the existing image then the boot command should boot the router back to the normal running mode (or a power cycle should do as well). If it has already erased the image in flash, then xmodem (or perhaps tftpdnld) is your recovery mechanism.

HTH

Rick

Danilo Dy Sun, 03/30/2008 - 19:01

Hi,

I'm not sure I'm getting it right as xmodem should not affect the router unless you override the image.

Have you tried checking the IOS in flash and manually boot from it? i.e.

dev << you can see from here if you only have embedded flash or you have a pcmcia slot.

dir flash

boot flash:ios_filename

What router model?

Regards,

Dandy

newnetman Sun, 03/30/2008 - 22:53

Hello sirs,

From your explanations i realized i might have tampered with the flash somehow, that was why it couldn't take me back to the normal bootup.

Then i decided to install the new image but the error message was "the image size exceed free flash space, how then do i proceed from here please?.

Thank you

spangdahlemcco Mon, 03/31/2008 - 02:02

If the image you are trying to place on the device is larger than the free space you are going to have to free up space. You can do a dir flash: or dir bootflash: depending on the device type and see where your memory is allocated. If you only have one IOS installed but still do not have sufficient space you will have to delete the current IOS before you xmodem the first one. This is a little risky because you will not have an IOS in ROM for a certain period of time. Also, xmodem is really slow, it may be better to connect it to a test switch or test lab depending on your setup and use Pumpkin or any tftp server program on a computer to TFTP the image onto the switch, but then the switch would need an IP.

I hope this helps.

newnetman Mon, 03/31/2008 - 03:38

Hello sir,

Would the dir flash: or dir bootflash: automatically delete the flash?, anyway i have tried it and the outcome is herein. because i don't mind loosing the content of the flash inasmuch as i can xmodem the new image onto it.

rommon 1 > dir flash:

device does not contain a valid magic number

dir: cannot open device "flash:"

rommon 2 > dir bootflash:

bad device name

usage: dir

rommon 3 >

I hope you can please take the pain to help me further?

Thanks

Danilo Dy Mon, 03/31/2008 - 05:28

No it won't delete it automatically.

Can you post the output of the following commands?

dev

confreg

BTW, what is your router model (again)?

Regards,

Dandy

newnetman Mon, 03/31/2008 - 07:43

Firstly, I am grateful for your willingness to help. The model is 3640 with 128MB and 24Flash.

Here are the output of dev and confreg,

Thank you

rommon 1 > dev

Devices in device table:

id name

flash: flash

slot0: PCMCIA slot 0

slot1: PCMCIA slot 1

eprom: eprom

rommon 2 > confreg

Configuration Summary

enabled are:

load rom after netboot fails

console baud: 115200

boot: the ROM Monitor

do you wish to change the configuration? y/n [n]:

Richard Burts Mon, 03/31/2008 - 08:10

OK. This shows that your router seems to have built in flash and also flash memory in slot0 and also slot1. There might be a valid bootable image in any one of these. If you can use dir commands or show commands to show the content of each, then look for a valid image file. If you find a valid image file then use the boot command to indicate the location of the image that you want the router to boot.

HTH

Rick

Actions

This Discussion