Nokia N95 with CCME-SIP

Unanswered Question
Mar 30th, 2008
User Badges:

Hi all,


I am trying to register my Phone (Nokia N95) with our CCME router. have anyone successfully set up this phone with CCME?


I have configured SIP on my CCME but it seems that there is a problem since I am getting some errors when I try to register the Phone (CCME Version 4.2)

Phone firmware/software is updated to the latest one ( ver 21...)


Here is the router config of the router


==========================


voice register global

mode cme

source-address 192.168.100.100 port 5060

max-dn 192

max-pool 58

timezone 44

dst start Oct week 8 day Sun time 02:00

dst stop Mar week 8 day Sun time 02:00

create profile sync 0005043018158482

!

voice register dn 1

number 260

name N95

!

voice register pool 1

id mac 001A.DCE2.E66C

number 1 dn 1

username **** password ****

codec g711ulaw

==========================

Debug output

Mar 31 04:30:26.223: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

REGISTER sip:192.168.100.100;transport=UDP SIP/2.0

Security-Client: digest

Via: SIP/2.0/UDP 192.168.17.10:5060;branch=z9hG4bK0jrrn6bc39hc7ui90buk4af;rport

From: <sip:[email protected]>;tag=c3obn6eodhhc682q0buk

To: <sip:[email protected]>

Contact: <sip:[email protected];transport=UDP>;expires=3600

Require: sec-agree

Proxy-Require: sec-agree

CSeq: 803 REGISTER

Call-ID: e5WXCr21oIeWhgbZgLh3ujuWQ7Zrk_

User-Agent: Nokia RM-159 V 21.0.016

Max-Forwards: 70

Content-Length: 0




Mar 31 04:30:26.227: //-1/xxxxxxxxxxxx/SIP/Error/sipSPICheckRequest: CheckRequest fail on method 100 error code: 6 and status: 420

Mar 31 04:30:26.227: //-1/xxxxxxxxxxxx/SIP/Error/act_idle_new_message: Failed check request

Mar 31 04:30:26.227: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 420 Bad Extension

Via: SIP/2.0/UDP 192.168.17.10:5060;branch=z9hG4bK0jrrn6bc39hc7ui90buk4af;rport

From: <sip:[email protected]>;tag=c3obn6eodhhc682q0buk

To: <sip:[email protected]>;tag=9D1CCC-E56

Call-ID: e5WXCr21oIeWhgbZgLh3ujuWQ7Zrk_

CSeq: 803 REGISTER

Unsupported: sec-agree

Reason: Q.850;cause=100

Content-Length: 0

==============================


Thanks

Nour

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jsivulka Thu, 04/03/2008 - 14:35
User Badges:
  • Bronze, 100 points or more

Could you please configure the following and then reset the SIP phones and see if it register:

voice service voip sip registrar server

(config)#voice register global

(config-register-global)#create profile

(config-register-global)#end


Please run the following debugs then make a failed call and send me the capture:


un all

debug ccsip message

debug ccsip error

debug voip ccapi inout


Also you need to do "create profile" under voice register global and then either reset the phone or reset the phone under

"voice register pool" if the phone is registered.


mnour401917_2 Thu, 04/03/2008 - 17:56
User Badges:

Hi jsivulka,


Thank you for your reply


I have attached the requested Debug and also added the (create profile) command.


Thanks heaps for your help.



Attachment: 

Actions

This Discussion