SSH and Telnet

Unanswered Question
Mar 31st, 2008

Hi All,

I have just upgraded my WS-2960G-48TC Switches, enabled SSH but I can access the Switch using both protocols - how can I disable Telnet and permit SSH

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
royalblues Mon, 03/31/2008 - 02:01

Under VTY config configure transport input ssh

line vty 0 4

transport input ssh

This will disable telnet on the vty lines



spangdahlemcco Mon, 03/31/2008 - 02:04

The above two messages are correct. However, you will need to type that command on vty 0 15 as well to ensure all vty lines require ssh connections.

Goutam Sanyal Mon, 03/31/2008 - 02:06

Hi Michael Buskin, With the addition of Narayan's post I'd like to suggest you to put " transport input all" under line vty 0 4. Thanks Goutam

royalblues Mon, 03/31/2008 - 02:09


Transport input all would enable telnet on the VTY lines which the user wants to disable :-)


Goutam Sanyal Mon, 03/31/2008 - 02:16

Hi Narayan, thanks you are right, just ignore the “disable telnet” I was sleepy. :) Thanks Goutam


This Discussion