Daylight savings for British Summer Time

Unanswered Question
Mar 31st, 2008

Hi,

I have a cluster to servers running CUCM 6.0(1).

I configured the Publisher to sync with two routers acting as NTP servers and the Subscriber syncs with the Publisher.

All this seems to working working ok and if I run "show status" on the server CLI I get the correct time and timezone as shown below:

admin:show status

Host Name : XXX-UCM2

Date : Mon Mar 31, 2008 11:53:21

Time Zone : BST

Locale : en_US.UTF-8

Product Ver : 6.0.1.2000-3

Platform Ver : 2.0.0.1-1

However, the phones show the non-daylight saving time - i.e. an hour earlier.

Daylight saving changed on 30th March in the United Kingdom.

Does anyone have any idea why the phones are showing the non-daylight saving time?

The device pool that the phones are in uses the Greenwich Mean Time timezone.

Is there some parameter I need to alter to get the phones to use daylight saving?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
jsivulka Fri, 04/04/2008 - 14:08

The IP phones will get their time from the callManager server. Just as with any Microsoft PC, the CallManager server can be setup to automatically adjust the time for day light savings time. To do this, click on the clock in the system tray, Click on the time zone tab, click the Automatically adjust clock for day light savings changes.

Check that the Windows server is really running NTP, because mostly they run a different, simpler, time protocol (TNTP?)

The NTP will synchronise your router to standtard UTC. You then set your timezine as an offset from that according to your winter time.

For the clock summer time, you specify what you want the timezone code to look like, and the dates and time that the offset should go forwards an hour. You can have it change automatically every year (recurring), and you can specify something like "last Sun Arp 02/00 last Sun Oct 03:00".

vpreenja Sun, 04/06/2008 - 13:19

7941-61 phones are java enabled phones and do not pick DST settings from call manager.. You need to upgrade there phone firmware and make them compatible to supoort DST.

I am sending you the link you the link for field notice. Pls check the phone firmware that you are working on and its supported firwware for DST.

If you are using any of the following phone models

7906, 7911, 7921, 7941, 7961, 7970, 7971

you need to upgrade your phone firmware to 8.2(2)sr1 or higher. As far as call manager is concerened, no modification are required in ccm 6.x. Pls refer the following doc for further queries.

http://www.cisco.com/en/US/products/hw/phones/ps379/products_field_notice09186a00807d3d9e.shtml

James Hawkins Sun, 04/06/2008 - 23:25

Thanks for the responses.

I actually found that the problem was due to the time zone I had set in the in the Date/Time Group configuration.

I had used GMT rather than GMT Standard/Daylight Time.

The CUCM 6.x interface makes you selct this from a drop down menu which hides half the descriptive text.

Now all running ok.

Actions

This Discussion