WCCP Debug Event

Unanswered Question
Mar 31st, 2008

Hi,

I'm implementing a transparent proxy using bluecoat. It uses WCCP between bluecoat and 3560.

Now it's working (the HTTP packet is redirected to the bluecoat), but when i do "debug ip wccp event", it shows these messages :

May 7 08:27:46.105 SGT: WCCP-PKT:D10: Sending I_See_You packet to 10.2.4.129 w/ rcv_id 00000058

May 7 08:27:56.112 SGT: WCCP-EVNT:wccp_update_assignment_status: enter

May 7 08:27:56.112 SGT: WCCP-EVNT:wccp_update_assignment_status: exit

May 7 08:27:56.112 SGT: WCCP-EVNT:wccp_copy_wc_assignment_data: enter

May 7 08:27:56.112 SGT: WCCP-EVNT:wccp_copy_wc_assignment_data: reuse orig mask info (1052 bytes)

May 7 08:27:56.112 SGT: WCCP-EVNT:wccp_copy_wc_assignment_data: exit

May 7 08:27:56.112 SGT: WCCP-EVNT:wccp_validate_wc_assignments: enter

May 7 08:27:56.112 SGT: WCCP-EVNT:wccp_validate_wc_assignments: exit

May 7 08:27:56.112 SGT: WCCP-EVNT: L2 adjacency added for 10.2.4.129

May 7 08:27:56.112 SGT: WCCP-PKT:D10: Sending I_See_You packet to 10.2.4.129 w/ rcv_id 00000059

May 7 08:28:06.111 SGT: WCCP-EVNT:wccp_update_assignment_status: enter

May 7 08:28:06.111 SGT: WCCP-EVNT:wccp_update_assignment_status: exit

May 7 08:28:06.111 SGT: WCCP-EVNT:wccp_copy_wc_assignment_data: enter

May 7 08:28:06.111 SGT: WCCP-EVNT:wccp_copy_wc_assignment_data: reuse orig mask info (1052 bytes)

May 7 08:28:06.111 SGT: WCCP-EVNT:wccp_copy_wc_assignment_data: exit

May 7 08:28:06.111 SGT: WCCP-EVNT:wccp_validate_wc_assignments: enter

May 7 08:28:06.111 SGT: WCCP-EVNT:wccp_validate_wc_assignments: exit

May 7 08:28:06.111 SGT: WCCP-EVNT: L2 adjacency added for 10.2.4.129

May 7 08:28:06.111 SGT: WCCP-PKT:D10: Sending I_See_You packet to 10.2.4.129 w/ rcv_id 0000005A

May 7 08:28:16.111 SGT: WCCP-EVNT:wccp_update_assignment_status: enter

May 7 08:28:16.111 SGT: WCCP-EVNT:wccp_update_assignment_status: exit

May 7 08:28:16.111 SGT: WCCP-EVNT:wccp_copy_wc_assignment_data: enter

May 7 08:28:16.111 SGT: WCCP-EVNT:wccp_copy_wc_assignment_data: reuse orig mask info (1052 bytes)

May 7 08:28:16.111 SGT: WCCP-EVNT:wccp_copy_wc_assignment_data: exit

May 7 08:28:16.111 SGT: WCCP-EVNT:wccp_validate_wc_assignments: enter

May 7 08:28:16.111 SGT: WCCP-EVNT:wccp_validate_wc_assignments: exit

May 7 08:28:16.111 SGT: WCCP-EVNT: L2 adjacency added for 10.2.4.129

May 7 08:28:16.111 SGT: WCCP-PKT:D10: Sending I_See_You packet to 10.2.4.129 w/ rcv_id 0000005B

It's repeated every few seconds.

Is it a behavior of the WCCP to add the L2 adjacency to the appliance constantly ? or is it an error ?

Thanks and Regards,

Richard Kristian

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Zach Seils Wed, 04/02/2008 - 04:15

Richard,

Can you collect a packet capture of the WCCP communication between the proxy and the switch? From the debug output, it seems that the proxy is updating the assignment information every 10 seconds.

Thanks,

Zach

RichardKristian_2 Wed, 04/02/2008 - 04:45

Hi Zach,

Thanks for the reply.

Unfortunately, i don't have access to the network at this moment. By the way, is there any issue if the proxy keep updating the assignment information every 10 seconds ?

Regards,

Richard

Zach Seils Thu, 04/03/2008 - 14:08

Generally this isn't a problem, since most of our platforms will ignore duplicate assignments.

Zach

Actions

This Discussion