High CPU Utilization

Unanswered Question
Mar 31st, 2008

Hi Guys,

I am having a 3845 router running the following image:

c3845-adventerprisek9-mz.124-11.T3.bin

The CPU utlization is very high (60-65%). Pls find enclose the attachment from the output from show process cpu command.

I am not able to find any errors on the router. I also try to find whether there is a bug in this image but could not find any. Does anyone else has got the same problem.

Any suggestion

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Mon, 03/31/2008 - 23:26

You have not mentioned how much traffic is being handled and which features are enabled. This information is always necessary.

1lumkk Mon, 03/31/2008 - 23:41

Hi Kuldeep,

Looking at the attached txt file, the highest recorded util is IP input (21%). It could be a false alarm, which I am not sure. It is good if you escalate this to your local vendor and have a TAC case open. Just in case.

spangdahlemcco Tue, 04/01/2008 - 00:33

What are you running on the router. Are your DHCP scopes on a separate router/server? You are using it as a VTP Server are you? What is the role of this router? It is always a pleasure to help out but information is needed.

kuldeep.kaur Tue, 04/01/2008 - 15:19

Hi Guys,

Tks for your replies. Please find attached the config of the router. The router is handing voice and data.

Rgds

Attachment: 
Joseph W. Doherty Tue, 04/01/2008 - 06:19

Realize that router's CPU usage does rise dependent on the amount of traffic flowing through the box. In your posted utilization, what might be further investigated is the large delta between total CPU utilization and interrupt CPU, in your attachment 27% (67%/40%). Most of this process switching appears to be within the IP Input process of about 21%. You might review http://www.cisco.com/en/US/products/hw/routers/ps359/products_tech_note09186a00801c2af3.shtml

Actions

This Discussion