Server NIC teaming on Catalyst 6509 Switch Problem

Unanswered Question
Apr 1st, 2008

Connecting a dual-nic HP server to a 3750 stack works fine; activity on both ports. When I try the same on a 6509, only one of the nics comes up.

Port config on 3750:

interface GigabitEthernet1/0/8

description host

switchport mode access

spanning-tree portfast

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Edison Ortiz Tue, 04/01/2008 - 11:50

Hi,

You mentioned 'teaming' at the server side but I don't see an 'etherchannel' configuration at the switch side.

What kind of teaming option have you selected in the server configuration tool?

If the 6509 detected the same MAC address originating from both NICs, it will block one of them. The 3750 was supposed to do that, not sure why it didn't /unless/ you configured etherchanneling which should correct the issue.

HTH,

__

Edison.

Michael Shepherd Mon, 06/28/2010 - 12:01

I also have a similar issue.

We have our servers set up with a teamed nic.  One nic connects to Switch1 and the other to Switch 2.  (for High Availability)

Both switches are 6509's.

Configuration for the switchports are:

sw

sw mode access

sw access vlan XX

spanning-tree portfast

no ip-address

When both nics are connected, we cannot ping the server.  When the team is broken (only one connection), we can access the server with no problems.

This is our standard set up throughout our datacenter and is only now giving us problems on 2 of our 4 Cat6509's.

Latchum Naidu Mon, 06/28/2010 - 13:39

Hi,

Teaming in Network switch side is Etherchannel. There might be different teaming types at server side.

Coming to etherchannel can be done on single switch and apply on multiple interfaces to boost up the traffic.

If I understand correctly, your scenarios is Server with 2 NIC's connected to 6509 switch (example NIC1 on gi3/21 and NIC2 gi3/27) If this is what correct do the below config and try...

Configure etherchannel on 6509:

interface Port-channel1
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan-number
switchport mode trunk

Assign etherchannel 1 on ports gi3/21 and gi3.27

interface GigabitEthernet3/21
description Connected to ServerNIC1
switchport trunk encapsulation dot1q
switchport trunk native vlan-number

switchport mode trunk
channel-group 1 mode on

interface GigabitEthernet3/27
description  Connected to ServerNIC2

switchport trunk encapsulation dot1q
switchport trunk native vlan-number
switchport mode trunk
channel-group 1 mode on

Regards,

Naidu.

bmath Mon, 06/28/2010 - 14:17

you go to HP tool and team the nic and select the fault tolerence with preference order then it will work no ether channel reqd.

Bmat

Hitesh Vinzoda Mon, 06/28/2010 - 21:20

How the teamed interfaces are connected, are they connected to different 6500's or on same 6500.

Hitesh Vinzoda

Actions

This Discussion