How to configure Aironet 1250 as stand alone AP?

Unanswered Question
Apr 2nd, 2008

Dear sir,

I have one Aironet 1250 AP,but I can't login into the configure mode via console or configure it via webUI, although it got ip from DHCP server.Can someone tell me how to configure it as stand alone AP? Thanks.

the "get ver" info via console are as below:

------------------------------------

get ver

Cisco IOS Software, C1250 Software (C1250-RCVK9W8-M), Version 12.4(10b)JA, RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2007 by Cisco Systems, Inc.

Compiled Wed 24-Oct-07 16:09 by prod_rel_team

ROM: Bootstrap program is C1250 boot loader

BOOTLDR: C1250 Boot Loader (C1250-BOOT-M) Version 12.4(10b)JA, RELEASE SOFTWARE (fc2)

AP001e.7a81.5706 uptime is 1 hour, 38 minutes

System returned to ROM by power-on

System image file is "flash:/c1250-rcvk9w8-mx/c1250-rcvk9w8-mx"

cisco AIR-LAP1252AG-A-K9 (PowerPC 8349) processor (revision A0) with 49142K/16384K bytes of memory.

Processor board ID FTX120590A1

PowerPC 8349 CPU at 533Mhz, revision number 0x0011

Last reset from power-on

LWAPP image version 3.0.51.0

1 Gigabit Ethernet interface

32K bytes of flash-simulated non-volatile configuration memory.

--More-- Base ethernet MAC Address: 00:1E:7A:81:57:06

Part Number : 73-10425-05

PCA Assembly Number : 800-27630-05

PCA Revision Number : A0

PCB Serial Number : FOC120205XR

Top Assembly Part Number : 800-29536-01

Top Assembly Serial Number : FTX120590A1

Top Revision Number : A0

Product/Model Number : AIR-LAP1252AG-A-K9

Configuration register is 0xF

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Rob Huffman Wed, 04/02/2008 - 06:07

Hi Alex,

The problem here is that the 1250 you received is a "Lightweight" model as shown by this part number from your info cisco AIR-LAP1252AG-A-K9. This model is made to operate with the Wireless Lan Controller type Unified deployment. You can convert it to Autonomous or Standalone mode using this method;

Using a TFTP Server to Return to a Previous Release

Follow these steps to revert from LWAPP mode to autonomous mode by loading a Cisco IOS release using a TFTP server:

--------------------------------------------------------------------------------

Step 1 The static IP address of the PC on which your TFTP server software runs should be between 10.0.0.2 and 10.0.0.30.

Step 2 Make sure that the PC contains the access point image file (such as c1200-k9w7-tar.122-15.JA.tar for a 1200 series access point) in the TFTP server folder and that the TFTP server is activated.

Step 3 On the PC where the TFTP server is located, perform these steps:

a. Disable any software firewall products, such as Windows firewall, ZoneAlarm firewall, McAffee firewall, or others.

b. Ensure all Windows files are visible. From Windows Explorer, click Tools > Folder Options > View > Show hidden files and folders.

Step 4 Rename the access point image file in the TFTP server folder to c1200-k9w7-tar.default for a 1200 series access point, c1130-k9w7-tar.default for an 1130 series access point, and c1240-k9w7-tar.default for a 1240 series access point.

Step 5 Connect the PC to the access point using a Category 5 (CAT5) Ethernet cable.

Step 6 Disconnect power from the access point.

Step 7 Press and hold MODE while you reconnect power to the access point.

Step 8 Hold the MODE button until the status LED turns red (approximately 20 to 30 seconds) and then release.

Step 9 Wait until the access point reboots, as indicated by all LEDs turning green followed by the Status LED blinking green.

Step 10 After the access point reboots, reconfigure it using the GUI or the CLI.

http://www.cisco.com/en/US/docs/wireless/access_point/conversion/lwapp/upgrade/guide/lwapnote.html#wp161272

Hope this helps!

Rob

alexzip1029 Thu, 04/03/2008 - 03:32

Hi Rob,

Thanks for your great help,I followed these steps and successfully upload image to my 1250.I also read the manual,however,I still can't login to the webUI.Based on manual,the default behavior of 1250 is DHCP client,but 1250 still can't get ip from my DHCP server.If configure it as static ip,what interface ip address do I need to set in order to use WebUI? Could you teach me how to login to the webUI?Thanks~

Below is "get ver" and "get run" info.

Cisco IOS Software, C1250 Software (C1250-K9W7-M), Version 12.4(10b)JA3, RELEASE SOFTWARE (fc1)

ROM: Bootstrap program is C1250 boot loader

BOOTLDR: C1250 Boot Loader (C1250-BOOT-M) Version 12.4(10b)JA, RELEASE SOFTWARE (fc2)

ap uptime is 23 minutes

System returned to ROM by power-on

System image file is "flash:/c1250-k9w7-mx.124-10b.JA3/c1250-k9w7-mx.124-10b.JA3"

cisco AIR-LAP1252AG-A-K9 (PowerPC 8349) processor (revision A0) with 49142K/16384K bytes of memory.

Processor board ID FTX120590A1

PowerPC 8349 CPU at 533Mhz, revision number 0x0011

Last reset from power-on

1 Gigabit Ethernet interface

2 802.11 Radio(s)

32K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address: 00:1E:7A:81:57:06

Part Number : 73-10425-05

PCA Assembly Number : 800-27630-05

PCA Revision Number : A0

PCB Serial Number : FOC120205XR

Top Assembly Part Number : 800-29536-01

Top Assembly Serial Number : FTX120590A1

Top Revision Number : A0

Product/Model Number : AIR-LAP1252AG-A-K9

Configuration register is 0xF

ap#sh run

ap#sh running-config

Building configuration...

Current configuration : 1367 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ap

!

enable secret xxx

!

no aaa new-model

!

!

power inline negotiation prestandard source

!

!

username Cisco password xxx

!

bridge irb

!

interface Dot11Radio0

no ip address

no ip route-cache

shutdown

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

shutdown

dfs band 3 block

channel dfs

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address dhcp client-id GigabitEthernet0

no ip route-cache

!

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

login local

!

end

Scott Fella Sat, 04/05/2008 - 20:31

you need to set the interface BVI1 with an ip address to be able to gui into the ap.

ahmedalshami Sun, 04/06/2008 - 00:00

Hi

all you need is switch on the pwoer and connect the console cable from AP to your LAPTOP and do this steps

en

conf t

interface BVI1

ip address 192.168.1.2 255.255.255.0

no shut

exit

exit

wr

then

configure your laptob to the same ip range and subnet

example

192.168.1.58

255.255.255.0

then reconfigure it using the GUI or the CLI

from GUI

configure SSID

and enable the RADIO

thats all

usmany Sun, 05/04/2008 - 04:05

Hi,

I got same problem getting my cisco AIR-AP1242AG-E-K9 configure via GUI/CLI, i came to a stage when boot-up via cli interface and got stopped at (*Mar 1 00:04:31.673: %LINK-3-UPDOWN: Interface BVI1, changed state to down

*Mar 1 00:04:32.673: %LINEPROTO-5-UPDOWN: Line protocol on Interface BVI1, chan

ged state to down) i am not getting the AP> prompt.

pls what would i do about it?

Scott Fella Sun, 05/04/2008 - 09:10

Console into the ap again and boot the ap and log everything and post it so we can see the whole log.

Scott Fella Mon, 05/05/2008 - 17:10

That log doesn't look normal. You should reload the IOS onto the AP and see if that helps. If not, then open a case with TAC.

What you can do is follow the cisco doc for lwapp to autonomous:

Using a TFTP Server to Return to a Previous Release

--------------------------------------------------------------------------------

Note This section does not apply to Cisco C3201WMIC and Cisco C3201LAP.

--------------------------------------------------------------------------------

Follow these steps to revert from LWAPP mode to autonomous mode by loading a Cisco IOS release using a TFTP server:

--------------------------------------------------------------------------------

Step 1 The static IP address of the PC on which your TFTP server software runs should be between 10.0.0.2 and 10.0.0.30.

Step 2 Make sure that the PC contains the access point image file (such as c1200-k9w7-tar.122-15.JA.tar for a 1200 series access point) in the TFTP server folder and that the TFTP server is activated.

Step 3 On the PC where the TFTP server is located, perform these steps:

a. Disable any software firewall products, such as Windows firewall, ZoneAlarm firewall, McAffee firewall, or others.

b. Ensure all Windows files are visible. From Windows Explorer, click Tools > Folder Options > View > Show hidden files and folders.

Step 4 Rename the access point image file in the TFTP server folder to c1200-k9w7-tar.default for a 1200 series access point, c1130-k9w7-tar.default for an 1130 series access point, and c1240-k9w7-tar.default for a 1240 series access point.

Step 5 Connect the PC to the access point using a Category 5 (CAT5) Ethernet cable.

Step 6 Disconnect power from the access point.

Step 7 Press and hold MODE while you reconnect power to the access point.

Step 8 Hold the MODE button until the status LED turns red (approximately 20 to 30 seconds) and then release.

Step 9 Wait until the access point reboots, as indicated by all LEDs turning green followed by the Status LED blinking green.

Step 10 After the access point reboots, reconfigure it using the GUI or the CLI.

If this doesn't work, try to convert the ap to lwapp and then back to autonomous.

http://www.cisco.com/en/US/docs/wireless/access_point/conversion/lwapp/upgrade/guide/lwapnote.html#wp176272

Actions

This Discussion