Inventory collection problem

Unanswered Question
Apr 2nd, 2008
User Badges:

I have just noticed that inventory collection is failing for several of my devices, devices ranges from cisco 4948 to 4006 and 2948. I have tried delete one cisco 4006 and added back in it and it never collected inventory on it.

RMECSTMServer and ICServer are runnig. When I look at the daemons.log it says "Connection terminated abnormally" I have attached the daemons.log output, please advise

I'm running LMS2.6 with RME 3.0.5 on Solaris 9



Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
David Stanford Wed, 04/02/2008 - 07:39
User Badges:
  • Cisco Employee,

What is the inventory error you are seeing? Anything in the IC_Server.log for the problem devices?

nawas Wed, 04/02/2008 - 08:10
User Badges:

I tried to manually collect inventory for two devices;

Cisco 4948 and I got the following error

RICS0001:Internal Error,unable to process the collected data from the device.

Cisco 4006 and I got the following error:Device Collection Failed.

Job details shows below:

Duration: 24.327 seconds

Average Scan Time: 24.327 seconds/device

Job Result Description: At least one of the devices that you submitted for inventory collection has failed

When I look at the IC_Server.log I see the following:

Primary key for table 'PhysicalAssetData' is not unique

I have attached current output from IC_Server.log

Thanks.




Attachment: 
nawas Wed, 04/02/2008 - 08:46
User Badges:

Thanks, Dave

I assume it is a free upgrade

David Stanford Wed, 04/02/2008 - 09:11
User Badges:
  • Cisco Employee,

Yes, you can download 4.0.6 from CCO as long as you have access to software downloads

jbarger Wed, 09/24/2008 - 13:46
User Badges:

I see the same error also on 4.1.1. 18 of my 250ish devices will not collect...


No ideas here :(

jbarger Wed, 09/24/2008 - 14:36
User Badges:

Well I just deledted the device entirely and put it back in and it fixed it...


I saw the error "ASA Error -193: Primary key for table 'PhysicalPort' is not unique"

in the ics_server.log.


Joe Clarke Wed, 09/24/2008 - 14:57
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

This problem is most likely due to one of bugs CSCso54489 or CSCsm97530. Both are fix in LMS 3.1, and patches are available from TAC for RME 4.0.6 and 4.1.1.

jbarger Wed, 09/24/2008 - 15:17
User Badges:

Ok Thanks... I saw 3.1 was available but didnt find it quickly so I will upgrade from 3.0.1 asap.


Actions

This Discussion