paolo bevilacqua Wed, 04/02/2008 - 08:14
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

These routers have a single fasthernet, so you need either an nm-1e, or a lan switch that supports vlans and use trunk/subinterfaces in the router.


Hope this helps, please help if it does!



Charlie Mayes Wed, 04/02/2008 - 08:37
User Badges:

My router already has a serial card in it as well as a built-in FastEthernet port. My 2950 switch does support vlan using dot1q. How would I connect my cable modem to my router using the serial WIC1 card?

paolo bevilacqua Wed, 04/02/2008 - 09:09
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

You can't. You can do:


interface fa0

ip address dhcp

ip nat outside


interface fa0.20

ip address 10.0.0.1 255.255.255.0

ip nat inside

encapsulation dot1q 20


ip access-list 1 permit 10.0.0.0 0.0.0.255


ip nat inside source list 1 interface fa0 overload


Note on router you need an ip plkus image new engough to support dhcp, on the switch set mode trunk to port going to router, access vlan 20 to ports going to PCs.


Cheers to Tina.


Hope this helps, please rate post if it does!


Charlie Mayes Wed, 04/02/2008 - 11:13
User Badges:

Ok, it seems like I need 2 ethernet ports and since the router only comes with one I need to purchase another one. Having the cable modem and the switch communicate through the same ethernet port is impossible. I do understand vlans and trunking. Also is the router capable of accepting dynamic IP ADDRESS from my cable modem. If so how is done or will the above directions on that festure on for the fa0 port. Please reply if what I am saying is right.

paolo bevilacqua Wed, 04/02/2008 - 11:17
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

All right. Not sure if your ios does dhcp, if does not, you need to upgrade IOS. Also I think vlans needs a plus image or router.

Charlie Mayes Wed, 04/02/2008 - 11:21
User Badges:

Got that part but, how do I get the fa0 port that my cable will be plugged into the recieve setting form my ISO's DHCP server. I mean what are the commands to tell the router it to recieve it automatically? I ahve never done this before.

paolo bevilacqua Wed, 04/02/2008 - 11:34
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

As mentioned before, "ip address dhcp".

That's it.


Hope this helps, please rate post if it does

paolo bevilacqua Wed, 04/02/2008 - 15:32
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

You're welcome.


As a recognition to those providing answers, please rate useful posts with the scrollbox below!

Actions

This Discussion