UC520 key system setup doesn't show caller ID

Answered Question
Apr 2nd, 2008

What else do I need to do here to get caller ID to show on my phones? Right now, incoming calls show as from AO, A1 and so on?

Thanks,

Diego

voice-port 0/1/0

connection plar opx 3A10

caller-id enable

!

voice-port 0/1/1

connection plar opx 3A11

caller-id enable

!

dial-peer voice 50 pots

destination-pattern A0

port 0/1/0

no sip-register

!

dial-peer voice 51 pots

destination-pattern A1

port 0/1/1

no sip-register

!

ephone-dn 30 dual-line

number 3A10 no-reg primary

label Line 1

call-forward busy 200

call-forward noan 200 timeout 10

trunk A0

!

ephone-dn 31 dual-line

number 3A11 no-reg primary

label Line 2

call-forward busy 200

call-forward noan 200 timeout 10

trunk A1

!

I have this problem too.
0 votes
Correct Answer by smalkeric about 8 years 7 months ago

Have you verified if the pots line plugged into FXO port has callerID service enabled ? You should be able to check that by plugging that line directly into an analog phone that supports callerID Meanwhile,

you may choose to configure following commands under voice port to spoof this info:

voice-port x/y/z

station-id num 1234567890 <--change to whatever you want

station-id name From PSTN

shut

no shut

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
smalkeric Tue, 04/08/2008 - 12:37

Have you verified if the pots line plugged into FXO port has callerID service enabled ? You should be able to check that by plugging that line directly into an analog phone that supports callerID Meanwhile,

you may choose to configure following commands under voice port to spoof this info:

voice-port x/y/z

station-id num 1234567890 <--change to whatever you want

station-id name From PSTN

shut

no shut

DIEGO ALONSO Wed, 04/09/2008 - 10:49

The num 1234567890 and name "From PSTN" do show for incoming calls. When those commands are not there only A0, A1, and so on show. Don't know what this tells me though?

DIEGO ALONSO Wed, 04/09/2008 - 11:49

Nevermind, I am an idiot. All our analog trunks have calledID EXCEPT the one trunk I used for testing!!!

Thank you for your help.

Diego

Actions

This Discussion