3750 bandwidth limitation between the same vlan over the trunk

Unanswered Question
Apr 4th, 2008
User Badges:

Hi All,


I have 2 3750G series switches on the trunk link. some machines are part of vlan1 on the switch 1 and some machines are the part of the same vlan1 on the other switch2. I need to limit the bandwidth between the switches for the vlan1. picture is attached.


I tried to do through the modulare policy frame work (class-map/service-map and policy-map using the police command) but problems are


1) 3750 does not support output service policy, so i cannot apply the policy on the output of the trunk link.

2) I can apply the input policy but it will be only for one machine but not for the others on the same switch. if i apply the policy on per port basis then every port has separate bw limitation. I require to limit the bandwidth on per vlan basis on the trunk port. like vlan 1 takes 10 MB, VLAN2 takes 10 MB on the trunk link when communicating between the same vlans.



Is there any solution for that scenario? your help in this case will be higly appriciated. As its the layer 2 communication, its hard for me to find the solution. if it was layer 3 then i can do it easily by using the rate-limit commmand on the interface.


thanks



Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

On the 4500 series we use vlan-range for this,


conf t

qos aggregate-policer 10MB 10 mbps 1250000 byte conform-action transmit exceed-action drop

policy-map 10MB

class class-default

police aggregate 10MB


interface GigabitEthernet1/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,10,12,15

switchport mode trunk

switchport nonegotiate

vlan-range 1

service-policy input 10MB

service-policy output 10MB

end


dunno if the 3750's have the same options

t4tauseef33 Wed, 04/09/2008 - 05:42
User Badges:

Hi Erik,


Thanks for the reply.


first of all 3750 does not support output policy on the layer 2 interfaces.


seconldy this configuration limits the bandwidth of any traffic from vlan 1 to any other vlan. but in my scenario i want to limit the bandwidth inside the vlan between the layer 2 interfaces.


If you found solution please let me know. thanks for your reply but it didnot solved my problem.


Thanks



t4tauseef33 Wed, 04/09/2008 - 06:11
User Badges:

hi ERICK,


3750 only supports input service policy for layer2 / trunk interfaces. output policy is not supported on layer 2 /trunk. there is output policy only on layer 3 interfaces like vlan/ip configured switch ports. Do you know anything else that can help me in this problem.


only 6500 or 3550 switch supports the output policy for layer 2. neither the switch 3650/2960/3560/3750.

t4tauseef33 Wed, 04/09/2008 - 07:35
User Badges:

Hi Erick,


but it will waste the trunk bandwidth. I want to save the bandwidth. my other switch is far away from this switch about 35 miles away using LES calbe.


if i apply the input policy on the other switch trunk interface. the packets will be dropped on the other switch and it will uttilize the trunk link as well.


any other solution

Actions

This Discussion