PVDM (Digital Modem) Configuration Issue

Unanswered Question
Apr 5th, 2008
User Badges:

I'm trying to configure a cisco 3825 (PVDM2-24DM) to connect to an analogue modem which can only run at 1200 baud. Therefore I need to fix the max/min connect speed of the digital modem's at 1200 baud. Looking at the documentation I believe I need to setup a modemcap to do this, since if you try to configure the speed on the line # it gives the message that you need to configure the speed using the AT commands. Also can anyone advise what would be best practice for setting up modem pooling, modem recovery etc. IOS V12.4


Many thanks.


Jonathan.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Makarand Chitale Sat, 04/05/2008 - 09:02
User Badges:
  • Cisco Employee,

Jonathan, please add the below modemcap,


conf term

modemcap edit v12_v22 miscellaneous &F+MS=1,0,1200,1200,,1200,1200


line x y

modem autoconfigure type v12_v22


Thanks, Mak

warnerjo41 Tue, 04/08/2008 - 05:16
User Badges:

Hi Mak, Many thanks for the info, i've tried this out however it does not seem to reduce the connect time significantly, any suggestions?. Also are you aware if at document for the AT command set for the 24-port MICA modems exists? Regards, Jonathan.

Makarand Chitale Tue, 04/08/2008 - 17:49
User Badges:
  • Cisco Employee,

Jonathan, is it the connect speed (1200 baud) or the connect time that you are looking for? We will need to use different AT commands to achieve them.


I think you are looking for AT commands for the PVDM2 digital modems and not MICA - correct?


AT Command Set and Register Summary for Cisco PVDM2 Digital Modems

http://www.cisco.com/en/US/docs/routers/access/pvdm/at/command/reference/atpvdm2.html


Just adding MICA as well in case you want it:

AT Command Set and Register Summary for Cisco MICA Six-Port Modules

http://www.cisco.com/en/US/docs/routers/access/modem/AT/Command/reference/atcmnds.html


Thanks, Mak

warnerjo41 Mon, 04/14/2008 - 06:50
User Badges:

Hi Mak,


Many thanks for the documents; however we would like to try to speed up the connect time to our 1200 baud modems, any suggestions? we are clearly connecting at 1200 baud since if you do a "show modem connect-speed" we see entries against 1200 baud. Currently if takes about 10-15 sec to make a successful connection.


Regards,


Jonathan.

warnerjo41 Mon, 04/14/2008 - 07:23
User Badges:

Hi Mak, one of our field engineers is asking what condition would cause the Async ports to be 'Administratively DOWN' since this is occuring a number of times?


Regards


Jonathan.


'Administratively DOWN' condition on the first of two ports I use - Async0/322.

ciscodeb#show interface Async0/322

Async0/322 is administratively down, line protocol is down

modem(slot/port):0/322, csm_state:IDLE_STATE,

bchan_num:-1 csm_status(0): CSM_STATUS_UNLOCKED


ciscodeb#show interface Async0/323

Async0/323 is down, line protocol is down

modem(slot/port):0/323, csm_state:IDLE_STATE,

I would be happy to know whether there are any internal mechanisms in cisco which would put the port into Down status

prince.gideon Sun, 06/15/2008 - 10:26
User Badges:

Hi Mak,

I've purchased 2 Cisco 1841 routers and a Cisco 2811. The 2811 is equipped with a HWIC-2CE1T1-PRI and a PVDM2-24DM module and will serve as a RAS. The 2 1841 will serve as remote access routers dialing the 2811 via an external Multitech modem. I've successfully set up the dial up between the 1841s. Clients sitting behind these two 1841s can reach each other and continuous pings get replied. However, the servers behind the 2811 seem unreachable. The Calling Switching Manager of the 2811 shows calls being disconnected and PPP debugging don't show that PPP phases are at all reached. I'd very much appreciate tips as to what could be wrong. I followed the examples in http://www.cisco.com/en/US/docs/ios/12_4t/12_4t11/htpvdm2.html#wp1077402 and http://www.cisco.com/en/US/docs/ios/dial/configuration/guide/dia_cfg_isdn_pri_ps6350_TSD_Products_Configuration_Guide_Chapter.html#wp1002870.


Below's my configuration:


Current configuration : 6901 bytes

!

! No configuration change since last restart

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname pstnrouter

!

boot-start-marker

boot system flash c2800nm-advsecurityk9-mz.124-15.XY1.bin

boot-end-marker

!

card type e1 0 2

logging buffered 51200 warnings

enable secret cisco

!

aaa new-model

!

!

aaa authentication login default local

aaa authentication ppp default local

!

!

aaa session-id common

network-clock-participate wic 2

network-clock-select 1 E1 0/2/0

network-clock-select 2 E1 0/2/1

!

modem country v12 e1-default

!

!

ip cef

!

!

no ip domain lookup

ip domain name genius.com

!

multilink bundle-name authenticated

isdn switch-type primary-5ess

!

!

spanning-tree uplinkfast

spanning-tree backbonefast

username cisco password 0 xxxxx

!

controller E1 0/2/0

linecode hdb3

framing crc4

pri-group timeslots 1-31

!

controller E1 0/2/1

!

!

!

!

interface Loopback0

ip address 1.1.1.250 255.255.255.255

!

interface Loopback1

ip address 172.16.100.250 255.255.255.255

!

interface Loopback2

ip address 172.16.30.254 255.255.255.0

!

interface FastEthernet0/0

ip address 10.199.199.250 255.255.255.0

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/1

!

interface FastEthernet0/3/0

switchport access vlan 12

!

interface FastEthernet0/3/1

switchport access vlan 12

!

interface FastEthernet0/3/2

!

interface FastEthernet0/3/3

!

!

interface Serial0/2/0:15

no ip address

encapsulation ppp

isdn switch-type primary-5ess

isdn incoming-voice modem

no cdp enable

!

interface Vlan1

no ip address

!

interface Vlan12

ip address 172.16.12.250 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Dialer0

ip unnumbered Loopback2

encapsulation ppp

dialer pool 1

dialer idle-timeout 300

dialer-group 1

no cdp enable

!

interface Group-Async0

no ip address

encapsulation ppp

load-interval 30

dialer in-band

dialer pool-member 1

dialer idle-timeout 300

async mode dedicated

no peer default ip address

group-range 0/322 0/345

!

router ospf 1

log-adjacency-changes

redistribute static subnets

passive-interface FastEthernet0/0

network 10.199.199.0 0.0.0.255 area 0.0.0.0

network 172.16.0.0 0.0.255.255 area 0.0.0.0

!

!

dialer-list 1 protocol ip permit

!

!

line con 0

line aux 0

line 0/322 0/345

modem InOut

transport input all

transport output all

!

end

paolo bevilacqua Mon, 06/16/2008 - 06:36
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, you may want to open a new thread for the different problem and include the debug output for the failed PPP connection.

prince.gideon Mon, 06/16/2008 - 10:27
User Badges:

Hi Paolo,


I should have thought of opening a new thread. After 5 days of trying to sort out this problem and the fact that it was my first time using the forum, I just dived into a thread I thought is related to my query.


By the way, I finally found the cause of the problem. We bought a PSTN simulator from the US. I rechecked the simulator settings morning only to find out that although I've selected Euro E1 PRI ISDN, the default compression algorithm on the simulator is u-Law (used in USA and Japan). Euro PRI ISDN uses A-Law. Changing that and selecting primary-net5 ISDN switch solved the problem.

paolo bevilacqua Mon, 06/16/2008 - 10:34
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, it's bit strange because the compaund type is carried in the call setup and the router normally adapts without the need to configure anything.

But good that you've resolved the issue anyway.

prince.gideon Mon, 06/16/2008 - 10:38
User Badges:

Could it be that the simulator doesn't emulator the 5ESS properly?

prince.gideon Mon, 06/16/2008 - 10:46
User Badges:

Hi, can you recommend some books that cover Cisco PRI ISDN and PVDM configurations in more depth? During this project, for which I'm the configuration engineer, I came across config techniques/topics that are not covered in my CCNA and CCNP books.

paolo bevilacqua Mon, 06/16/2008 - 14:39
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

One should look at a call trace to tell.


I think some cisco book do cover these things, but in telecom and networking there is no substitute for reasoning ans experience.

Actions

This Discussion