IVR Prompt Error - TCL Script

Answered Question
Apr 5th, 2008
User Badges:

I'm trying to get the 'clid_authen_collect' built in script working. I continue to get the below error.

" enter_account.au

errno=0=Unsupported samples per secondpr"


I used Audacity to create prompts with below specifications:

Default Sample Rate: 8000Mhz


Default Sample Format: 32-bit float


Uncompressed Export Format: AU Sun/Next 8-bit Ulaw


channels: 1 (mono)


FFT Size: 64


Can someone who's created prompts in the au format let me know what exact specs the router wants in order to execute the prompt.


thanks in advance,


Correct Answer by paolo bevilacqua about 9 years 3 months ago

Yes, you need DSPs.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Kenneth Mohammed Sat, 04/05/2008 - 08:30
User Badges:
  • Silver, 250 points or more

the specs are as follows


codec- G711ulaw

8 kHz

8 bit

Mono


other than that, im not too familiar w/Tcl, so im not sure why you are having an issue.

UCcomp2007 Sat, 04/05/2008 - 08:35
User Badges:

Appreciate the quick response. Do you know of another recording utility that I can use to create the .au audio files?

Kenneth Mohammed Sat, 04/05/2008 - 08:42
User Badges:
  • Silver, 250 points or more

Im not really sure, like I say, Im not too familiar with this sort of thing, I just happened to know the spec, but Ive never had to make an actual recording.

paolo bevilacqua Sat, 04/05/2008 - 09:00
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, the problem is the sample format that I think should 16 bits, not 32.

Anyway, to record prompts in a simple way, you can use the recorder that I wrote:

http://pbevila.fastmail.fm

You can use it with any voice device that can call the service one way or another.


EDIT: I haven't checked, it can very well that sample has to be 8 bits as mentioed above.

Hope this helps, please rate post if it does!


UCcomp2007 Sat, 04/05/2008 - 09:42
User Badges:

HI Paolo.


I got a directory index denied when I tried to hit your page. I'd love to try your recorder out.


After my last post, I used the Switch Sound File Converte and I no longer get that error, but I still can't hear the prompt.


As always i'll rate the post before closing this issue out.


Regards,

UCcomp2007 Sat, 04/05/2008 - 09:44
User Badges:

BTW, last format that I save with Switch Sound File Converter was:


output format .au

codec: ulaw

sample rate 8000

channels mono


It doesn't give me the option under Ulaw to save as 16 bit. If I switch to PCM I could define 16 bit.






UCcomp2007 Sat, 04/05/2008 - 10:02
User Badges:

Paolo,

I added /public to URL and was able to get in.


However I took one of your prompts, renamed it and uploaded it. When I do a debug voice application media packet I see the prompt is active, but still no sound heard. Any ideas?


Attached is my config if you have time to look.



Attachment: 
paolo bevilacqua Sat, 04/05/2008 - 10:12
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, you need codec g711u for all and any DP that has tcl/ivr service with prompts.

paolo bevilacqua Sat, 04/05/2008 - 10:08
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Sorry, here's the correct url:


http://pbevila.fastmail.fm/public


Also, if you download:

http://download-sj.cisco.com/cisco/access/tclware/debitcard-multi-lang-Cisco.1.1.0.2.zip


There's a lot of prompts in there that you can reuse.


finally remember that for "static" prompts, when prompts change, you ned to reload the router to load the new one. That is a current issue in IOS.

UCcomp2007 Sat, 04/05/2008 - 11:24
User Badges:

I'm trying to get your script to run. I really want to get this running as I have a real need for it. I loaded script and prompts in flash, rebooted, then configured applicaiton and voip dialpeers. When I call from one router over to this one, I am getting an error "Error Adding URL to Prompt list". Do you know why this happens? I've attached config and debug voice application error.


appreciate your help.



paolo bevilacqua Sat, 04/05/2008 - 11:40
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Please configure paramspace commands for the script.

UCcomp2007 Sat, 04/05/2008 - 13:41
User Badges:

Still no luck. Let me ask you, even though all calls to and from router running TCL are using G711, do I still need DSP resources? If so, does the router grab available DSP's (maybe to play the prompts) or do you have to have a transcoder setup?


sorry for the hassle.

Correct Answer
paolo bevilacqua Sat, 04/05/2008 - 14:55
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Yes, you need DSPs.

Actions

This Discussion