%DOT1X_SWITCH-5-ERR_ADDING_ADDRESS: Unable to add address

Unanswered Question

Hi all. Here's the situation. We have a L2 3550 access switch dual-uplinked to 2 L3-6513 distributions running OSPF. The uplinks are L2 trunks. Last night the switch began issuing the following error: "%DOT1X_SWITCH-5-ERR_ADDING_ADDRESS: Unable to add address x.x.x.x on fa0/x" on multiple interfaces. Approximately 30 minutes into the issue the management Vlan on the 3550 began flapping up/down.

At the same time the OSPF adjacencies on the 2 distributions went down. The log also shows the HSRP standby addresses on the distributions being duplicated (we've run into this issue before due to processor overload, so I doubt the addresses were actually being overloaded).

We ended up shutting down one of the uplinks on the 3550 and all adjacencies returned.

Any ideas? Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

We believe the 3550 was having a TCAM error where the table became full. This issue caused STP events to occur over the trunks. The distribution switches were seeing duplicate IP's for our wireless segments since it thought they were coming from 2 different access switches when in fact it was only 1. Due to this error, the OSPF process though it had issues within the routing table and proceeded to flush the table and relearn the entire table instead of just the updates. This was happening every 10-30 minutes. When we shutdown one of the uplinks all errors ceased, and normal OSPF & STP operation returned.

Any thoughts on this? Thanks.

Actions

This Discussion