c3750-12s routing issue

Unanswered Question
Apr 5th, 2008

I need help with a strange problem.

We currently have c3750 12 & 24 port ipbase image closet switches that connect to

a stack of 4 c3750-12s ip enhanced imaged switches. The closet switches connect to

the distribution switches via cross stack layer 2 etherchannel the 3750-12s distribution

stack connects to a 6506 core switch via cross stack layer 3 port channel.

Here is my problem :

Host A & B are on the same closet switch, same subnet and same vlan. Host A can ping host C

which is on the other side of the 6506 switch and Host B cannot. Both A & B can ping

another host on C's subnet. When running a trace route on problem the packets stop at the

12s distribution switch. Yet the 12s distribution switch can ping both Host B and C.

There are no ACL's and utilization is minimal. The proper routes are in the routing table

and there are CEF entries for the destination.

Cisco TAC is Looking at the issue but is stumped so far. The problem actually includes multiple

source and destination addresses and any connectivity to them not just pinging but the example

is the problem in a nutshell. We have to shutdown one of the layer 3 port channel link so

the problem does not return. (it doesn't matter which link).

Tried:

Clearing routing table, turning CEF off, changing load-balancing algorithm on switches to

ip src-dst, changing master switch in stack to switch #2, rebooting stack (which will clear

the issue for a day to week or so ). Cisco has checked the config of thes switches and they

look good.

anyone seen anything like this?

Our next option is to upgrade IOS on the 12s's .

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
msooley Sat, 04/05/2008 - 17:55

can you post the interface configuration of where A and B are connected? Are you using DHCP or static addressing? Check the subnet mask on A and B to ensure the are the same. Ensure you do not have any private ports or protected ports in place for A and B.

sr2198808 Sun, 04/06/2008 - 16:43

The access port config is good and the addressing is dhcp . The problem is not with the hosts, mask or access port config. These

hosts can connect fine for a while then will suddenly stop. The problem is that the 12s distribution switch will stop passing a connection between certain addresses but if

you shutdown 1 of the 2 links in the portchannel between the distribution and core layer the connection will start again and run fine. Hope this info is helpful.

lxcollin1 Sat, 04/26/2008 - 17:54

I have this exact problem with my 3750E's version 12.2(40). Which IOS are you running? Did you find a resolution?

Actions

This Discussion