Supervior Desktop Monitoring

Unanswered Question
Apr 7th, 2008

UCM 5.1.2

IPCC 4.5

I am attempting to monitor an agent. I choose the agent, select the "silent monitor" button, and then what? How do you here the conversation? Through your phone or PC?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
kre8or2007 Thu, 04/10/2008 - 05:40

It goes through the sound card to your PC speakers. You must, however, make sure the NIC in your PC is supported.

spotlight41 Thu, 04/10/2008 - 11:51

Yeah, I've been on TAC for two days now without any luck. The guy doesn't even know the Windows Trace Route command, which scares me. He's got me doing reg hacks and everything. It just doesn't seem like it should be this hard!!!

s5rch Thu, 04/10/2008 - 12:03

Hello,

Well Im not TAC but here are a few suggestions:

1. You have to ensure that your span port is enabled on the phone station in Call Manager (if your using 7941 and up).

2. Sometimes even if you see it enabled on the phone page in Call Manager you should look at the web page (Network Config) and ensure its enabled. I have found that if its not enabled on that page it could be a firmware issue.

3. Also, what type of NIC card are you using in your PC's?

"Certain NICs are configured by default to strip VLAN tags, which does not allow Desktop Monitoring to work. These NICs have published instructions for how to manually configure them to pass VLAN tags:

Note: If your NIC is not listed here, refer to your NIC and/or PC manufacturer's documentation.

Intel PRO/100 and Intel PRO/1000

Broadcom NetXtreme Gigabit "

What version of Cisco Supervisor Desktop are you using? What type of phones are you using?

I have other ideas but do not want to overload you.

Hope it helps.

spotlight41 Thu, 04/10/2008 - 12:09

1. span port is enabled.

2. at the "web page"? Not sure where you mean here.

3. We're using Intel Pro\100 and Broadcom 440x. TAC has performed some reg hacks.

4. CSD ver. 6.2(1)

s5rch Thu, 04/10/2008 - 14:59

Spotlight41,

The web page is in the Call Manager device/phone. You should see the IP address on the right side of the page (at least it is in 6.X). You click on the IP address and it will bring up a Web page. In the left column of that page click Network Configuration and scroll to the bottom of the screen ..look for Span Port enabled (it will say Yes or No).

2. Have you double checked your Desktop Admin VOIP server configuration to ensure that each Agent login is pointing to the correct VOIP server or default VOIP server?

3. Did you run a Cisco Agent Debug as well as Cisco Supervisor Debug (Level=500)? If so can you attach them to the reply.....

spotlight41 Fri, 04/11/2008 - 03:50

I understand now where to look for the span port enabled on the web page, and yes, it's enabled.

The Desktop Admin is set correctly for monitoring.

I'm not sure how to run debugs on CAD and CSD. ...and I would have to run debug while attempting to monitor???

stephane.bordenave Fri, 04/11/2008 - 04:08

check your codec, only G711 and G729 are supported for desktop monitoring.

Disable also any firewall and antivirus on agent pc.

spotlight41 Fri, 04/11/2008 - 04:15

codec is G711.

I've disabled firewall and antivirus to no avail. TAC says all settings are fine and they don't know why it isn't working.

s5rch Fri, 04/11/2008 - 04:27

Attached are two Basic "how to instructions” on how to setup debug for the Supervisor and Agent. I use these if I have tried everything else.

You have already tested the actual sound card in the PC correct? I'm sure you probably and now that you have verified that everything is setup properly then I would take a chance using the debugs and see what they tell you. You should get your desktop Agent debug, CSD debug, and the Agent you are trying to monitor's debug.

Thought:

When you're trying to monitor an Agent from CSD you are logged into your Agent correct (but in a not ready mode)?

spotlight41 Fri, 04/11/2008 - 04:33

s5rch,

Thank you very much for the help. When I'm attempting to monitor an Agent from CSD, I am logged into my agent, just not in ready mode, just as you say.

Sound card is tested.

I'll check these "how to's" out. Thanks again.

spotlight41 Fri, 04/11/2008 - 07:01

I now have the 3 debug files, but now I don't know what to do with them. What should I look for?

s5rch Fri, 04/11/2008 - 07:23

You have to follow the trail....debugs are so messy at times its the only thing you can do. If you know the agent was on a live call when you ran the debugs look for the conversation. You should see be able to see everything from when you turned click your monitoring button to the end of the call. Feel free to block out the extension/ip addresses on the debug and attach them..and I will take a look. I would also attach them to your Cisco TAC case at [email protected]. Perhaps the TAC Engineer would also want to take a look at them.

overbc01 Fri, 04/11/2008 - 11:47

I had this problem until I replaced my Intel NICs Card with a Broadcom. TAC has a list of cards that they have tested. I have had no problems with Broadcom NICs but Intel cards are occassionally problems.

Actions

This Discussion