LMS 3.0 - RME "Error creating archive"

Unanswered Question
Apr 7th, 2008
User Badges:

Hi All


All of my config archives are failing with error:

"CM0020: Error creating archive"

Im also getting a lot of:

"Couldnot copy file contents from 20080408091310812-10.134.47.146.cfg to 11-20080408091307.cfg."


A bit of history:

I recently changed the hostname of my server and ran the LMS script to update everything. Unfortunately, things didnt seem quite as stable as before so I re-installed (this is pre-prod).


So I then did a backup restore and since then, im getting the above errors. *none* of my configs are being archived.


Ive tried removing all the configs from the ciscoworks tftpboot directory and ive also checked the permissions of that directory.


Now, the thing is, the .cfg files are being created in the tftpboot directory, but if I open them, they are garbled. Is this the correct behaviour? And if it is correct, why is it still showing as failed in RME?


Thanks in advance.

Matt





  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
miheg Mon, 04/07/2008 - 04:48
User Badges:
  • Gold, 750 points or more

There is a bug that causes this.


It could be CSCse52700 or releated to that.


You will have to open a TAC case and give them your RME version to get the patch.


Cheers,


Michel

mattbauer Mon, 04/07/2008 - 05:38
User Badges:

Ah, that's unfortunate. I dont have smartnet on this yet.

Does anyone know of any workarounds or quick fixes that I can use until I can raise a TAC case?

David Stanford Mon, 04/07/2008 - 05:57
User Badges:
  • Cisco Employee,

Have you enabled the shadow directory? If you enable it, try to delete a device and re-add it to RME. Can it now archive the config?


You should never move any config file from its default location, RME handles all of the moving within the filesystem.


mattbauer Mon, 04/07/2008 - 06:55
User Badges:

Yep, I have shadow directory enabled.

Ive tried disabling it then deleting/adding devices and vice versa. No luck. All devices are always Failed.


I removed those files from the tftp directory as a test to see if it had any effect. But I have put them back now. I dont notice any difference either way.

mattbauer Mon, 04/07/2008 - 19:28
User Badges:

Guys, thanks for your help, but I ended up re-installing and this time *not* restoring from backup. The archives are working nicely now.

Thanks again.

Matt

Actions

This Discussion