LMS 3.0.x individual app install

Answered Question
Apr 7th, 2008

Hello. When the original 3.0 install of LMS was completed, individual applications were left out of the install because a customer did not want them, but has since changed their mind. The original install was patched so it is not the same version that comes on the DVD. How can you go back and use the DVD to install other applications from the LMS package? If you try to use the DVD it complains that the version on the DVD is older than the version installed. How can I get around this issue and install the other applications?

Thanks

I have this problem too.
0 votes
Correct Answer by Joe Clarke about 8 years 7 months ago

This is a bug, CSCsj94584.

Symptom:

When LMS is installed and any of the applications are patched, no additional applications can be installed and an error message appears.

For example, the following error message appears

Cannot install CiscoWorks LAN Management Solution(CM). You are trying to

install an earlier CM Version (5.0.0) over a later version (5.0.1).

Cannot install CiscoWorks LAN Management Solution(DFM). You are trying

to install an earlier DFM Version (3.0.0) over a later version (3.0.1).

Conditions:

This occurs when LMS applications are patched after installation, and then a new application is installed.

For example, if Campus Manager and Device Fault Manager are patched to LMS 3.0 December 2007 Update in a CiscoWorks Server, you cannot install Internetwork Performance Monitor 4.0.

Workaround:

1. Modify the .info files for the patched modules under NMSROOT/setup and set the value of PATCHVER in these files to their original value of 0.

2. Install the new application on CiscoWorks Server.

3. Reset the values of PATCHVER to their patched versions after the installation is complete.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Joe Clarke Mon, 04/07/2008 - 08:32

This is a bug, CSCsj94584.

Symptom:

When LMS is installed and any of the applications are patched, no additional applications can be installed and an error message appears.

For example, the following error message appears

Cannot install CiscoWorks LAN Management Solution(CM). You are trying to

install an earlier CM Version (5.0.0) over a later version (5.0.1).

Cannot install CiscoWorks LAN Management Solution(DFM). You are trying

to install an earlier DFM Version (3.0.0) over a later version (3.0.1).

Conditions:

This occurs when LMS applications are patched after installation, and then a new application is installed.

For example, if Campus Manager and Device Fault Manager are patched to LMS 3.0 December 2007 Update in a CiscoWorks Server, you cannot install Internetwork Performance Monitor 4.0.

Workaround:

1. Modify the .info files for the patched modules under NMSROOT/setup and set the value of PATCHVER in these files to their original value of 0.

2. Install the new application on CiscoWorks Server.

3. Reset the values of PATCHVER to their patched versions after the installation is complete.

Actions

This Discussion