2811 Router PBR : Two ISPs : Mail --> ISP1, Browsing --> ISP2

Unanswered Question
Apr 8th, 2008

Hi all,

We have a scenario where there is a 2811 router, connected to two ISPs ( ISP1 and ISP2). The requirement is that Email has to be forwarded through ISP1 and browsing should happen through ISP2. But if link to ISP1 fail then mail should go through ISP2 and when the link to ISP1 comes up back again mail should go through ISP1 again. Similarly for browsing.

Is this possible? Are there any configuration samples available?

Thanks and Regards

Sonu.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
royalblues Tue, 04/08/2008 - 01:57

For multihoming you should have your own public address space. If you do not own the address space it is more likely that ISP 1 would drop the packets for ISP2 subnets and vice versa

If you own the address space, you can force the mail traffic on the outbound direction but we cannot guarantee the inbound direction of the traffic

eg config

interface Ethernet0/1

Description inside

ip address 10.10.10.1 255.255.255.0

ip policy route-map mail

interface serial 0/1

description " ISP1 link "

ip address 20.20.20.1 255.255.255.252

interface serial 0/2

description " ISP1 link "

ip address 30.30.30.1 255.255.255.252

ip route 0.0.0.0 0.0.0.0 30.30.30.2

ip route 0.0.0.0 0.0.0.0 20.20.20.1 20

route-map mail permit 10

match ip address 1

set ip next-hop 20.20.20.2

access-list 1 permit host

HTH

Narayan

Actions

This Discussion