Transcoding misunderstanding

Unanswered Question
Apr 8th, 2008

Hi all,

I have a question regarding transcoding between 2 sites.

We currenlty have 2 sites with 2 H323 VGW (one on each site). Within each sites we use G711 and between them G729.

So site A use his own device pool with regionA configured. Site B use device pool with regionB.

When a phone on site A calls site site B, it uses G729.

But now we are implementing a Opertor server which only allow G711. The server is located on siteA.

So now when someone from siteB call the application, the calls is dropped (codec unsupported).

That's why we want to implement transcoding now.

I configured two Xcode on each VGW, configured it on the CUCM6.1, each in different MRG and device_pool.

Now my question is: How it works ????

My understanding is:

Phone from siteB calls the Operator extension on siteA.

The call leaves the phones, contact the CUCM who check the region and see that the call has to be placed in G729.

So the RTP audio leave the phoneB, go trough the WAN in G729, arrive on the VGW_Site_A, who transcode the RTP flow in G711 to be accepted by the Operator server ???

True or Not ??? For this example, is the Transcoder on VGW_Site_B used or not ???

Thx for your help. I really don't understand how does it work...


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Jaime Valencia Tue, 04/08/2008 - 07:21

youre right on your understanding on this, the phone that will ask for the XCODING will be the operator, if the MRGL only has XCODER from site A then the resources will be used from that one

its impossible for that phone to use resources from the other XCODER since its not in the MRGL, it should only have access to on-site resources, in this case from site A



if this helps, please rate

f.giordano Tue, 04/08/2008 - 07:32

So it seems that design is Ok isn't it ?

All device from site_A need to be in the DP with local XCoder. And same thing for site B (each site with local ressource).

And regarding the region configuration between each site in the CUCM, I keep the current settings (I mean G729 between site and G711 within site), right ?


for ur help


jbarcena Tue, 04/08/2008 - 07:37

Yes, your configuration is correct. And well the best practice is always to use G.711 within the same site and G.729 with the remote sites, so you should be fine as you are at this moment.




This Discussion