cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
250
Views
0
Helpful
2
Replies

Policing question, 1811

jbartlett19
Level 1
Level 1

I am trying to configure the WAN side of an 1811 to 1) provide priority to video, 2) limit the bandwidth used by video, and 3) limit the bandwidth used by all traffic. The output of the 1811 is 100 Mbps, but it soon drops to 2.4 Mbps at a wireless modem, so I want to limit at the router so QoS works correctly. Here is my config so far:

class-map match-all VIDEO_DSCP

match ip dscp af41

class-map match-all INTERNET

match not access-group 121

class-map match-all ALL-TRAFFIC

match any

class-map match-all INTERNET_DSCP

match ip dscp default

class-map match-all VIDEO

match access-group 121

!

!

policy-map ingress_mark_policer

class VIDEO

set dscp af41

class INTERNET

set dscp default

policy-map egress_policer

class VIDEO_DSCP

priority 960

policy-map egress_policer_parent

class VIDEO_DSCP

priority 960

police 960000

class ALL-TRAFFIC

shape average 2400000

!

!

!

bridge irb

!

!

!

interface FastEthernet0

description $ES_WAN$$FW_OUTSIDE$

ip address 192.168.1.58 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat outside

ip virtual-reassembly

ip route-cache flow

duplex auto

speed auto

service-policy output egress_policer_parent

!

I am testing with data and video simultaneously. Video limits to 960K, data traffic limits to 2.4M, but when together they run to a combined 3.4 Mbps so my overall traffic shaping is not working. How do I combine the two requirements so data can use the video bandwidth when available but backs down when video is running? Thanks for any help.

JB

2 Replies 2

Joseph W. Doherty
Hall of Fame
Hall of Fame

(pseudo config)

service-policy parentshaper

class class-default

shape average 2.4 Mbps

policy childQoS

service-policy childQoS

class VIDEO_DSCP

priority 960 Kbps

interface FastEthernet0

service-policy output parentshaper

Worked like a charm. Thanks for taking time to help me out. JB

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card