Diff. CM version -Pros & Cons

Unanswered Question
Apr 8th, 2008
User Badges:

Hi experts,


we have existing CM 4.1(3) version and would want to upgrade to either 4.3, 5, or 6.


Can anyone would want to comment on what are the pros & cons for each version?


tnx


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Tommer Catlin Wed, 04/09/2008 - 08:10
User Badges:
  • Green, 3000 points or more

I would go right to 6.1 if you can. Get out of Windows. It's much more stable, easy to support (software and patches, etc). BUT, if you have some sort of customized CUCM 4.x box with 3rd party software, that might be hard. The SDK pack in particular, some clients have customized phones, TAPS, etc that do not work in the Linux world. My experience? about 5-7 years of CUCM. I prefer the linux version over windows.

garydaemyir Wed, 04/09/2008 - 08:37
User Badges:

I agree. If you need to keep windows for some reason, then 4.3. Otherwise I would recommend 6.1.

Jaime Valencia Wed, 04/09/2008 - 10:06
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

the migration to 4.3 is essentially almost the same, you need to wipe out your server and then apply a backup file during install. if you ask me i'd rather go to 6.1 than 4.3 or 5 if i have to do the same procedure.


6.1 provides the unified mobility, some new features like the intercom, DND separate from IPMA just to mention some of them. Also has support for SIP devices which 4.3 doesn't have.


HTH


javalenc


if this helps, please rate

redrobish Wed, 04/09/2008 - 17:16
User Badges:

How about the licensing? Heard that main issue is licensing they (cisco) went to a feature based license which is terrible. Also we should expect to pay a couple hundreds dollars to license it on the server. That is per phone?


How about the diff bet 5.x & 6.x?


tnx

Jaime Valencia Wed, 04/09/2008 - 17:37
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

right now in our licensing and upgrade model for the upgrade from a 4.x flavor to a 5.x or 6.x the DMA takes care of getting you the necessary DLUs for the target release you choose. so ALL you had working with 4.x will continue to work with the linux versions thanks to the DMA procedure and the upgrade model that we offer.


since all the phones you buy contain a PAK that entitles you to get the necessary DLUs to use it, it's not that we ask you to buy the phone and buy the license apart.


Each phone model consumes an amount of DLUs, that changes between the 5.x and 6.x version (as phones grow older less DLUs are necessary)


some things like the GWs do not consume DLUs basically the devices do consume DLUs. Features like presence, enable a phone for video and some others also consume DLUs, usually just 1 or 2 depending on the feature.


right now the two licensing models are regular DLUs and CUWL (Cisco Unified Workspace License) which can be considered a "per user" license which gives you the phone, VM, presence, etc DLUs necessary for all the features for one user.


personally i think it's best the regular DLU model if you do not plan to implement the whole suite of solutions but that depends on what you're going to have, maybe CUWL suits better your needs, who knows?


the licensing scheme is basically the same for 5.x and 6.x, the difference is how many DLUs a device takes. i don't have my servers right know to give real numbers but lets say a 7940 takes 4 DLUs in 5.x and 3 in 6.x, why?? because when 6.x was released that phone was older than when 5.x was released.


HTH


javalenc


if this helps, please rate

Tommer Catlin Wed, 04/09/2008 - 17:42
User Badges:
  • Green, 3000 points or more

You are basically grandfathered into the new license standard from 4.x to 5/6. So if you have 1000 phones and 2 nodes, you will have the same in 5/6. Getting to that point can be a pain. It's not a "smooth" transition, but once it's done, it's done. Yeah, DMA takes care of some of it, but you still have to send excel sheets back and forth to Cisco for licenses, etc. Make sure your contracts are up to date, etc.


Between 5/6. There are some more features in 6. 5 was kind of a bomb of a platform. It worked in some places, but the early releases did not work very well. 6.1 is great. The extra features, improvements in SIP really help out. basically, if you are going to do all the work to upgrade from 4.x, skip 5 and go right to 6.1


But just around the corner is 7.0... so get ready!

Actions

This Discussion