BRI configuration

Unanswered Question
Apr 9th, 2008

Hi Guys,


I really need some help with the configuration of 3 ISDN BRI circuits in Europe.I have a 2800 series with 3 bri`s in the back which the site will use for incoming and outgoing calls.I have never setup BRI`s before only E1`s so not sure where to even begin.If someone could please point me in the right direction or perhaps give me an example of what my config should look like it would be much appreciated...thanks in advance!!!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
shaunswales Wed, 04/09/2008 - 02:30

Hi There also have the same problem. Using a 2800 with 4 BRI ports connecting to Premicells to allow outgoing calls to the different Mobile operators in South Africa. If you come right please give me shout, if I find something relevant will let you know

Thanks

Shaun

Paolo Bevilacqua Wed, 04/09/2008 - 02:40

You can use the configuration I suggested.


The most important thing you've to find is if your premicell devices require router to be network or user side, and if static tei is required. Possibly they can work both ways, just configure router accordingly.


After that, you troubleshoot with "debug isdn q931" and "term mon".

Paolo Bevilacqua Wed, 04/09/2008 - 02:32

Ar the lines in hunt-group ? If so the config will be likely:


int bri 0/0/0

isdn switch-type basic-net3

isdn static-tei 0

trunk-group bri

isdn overlap-receiving <--- not always required, but doesn't hurt

ised sending-complete <-- same as above


int bri 0/0/1



dial-peer voice 111 pots

destination-pattern 0....T

trunkgroup bri


Note in many countries you can also eliminate the prefix digits (0 or 9) for external calls. Just make you extension all begin with an unused digit. users like that very much because it's "like calling from home".


Hope this helps, please rate post if it does!



Steellllllllll0 Wed, 04/09/2008 - 03:47

Hi Brilliant !!


Just what i needed. I can now see the calls come in on debug q931 but when i added the trunk group bri to my pots dial peer the calls got rejected.Once i removed it,the call comes in as normal but i then get a type of dial tone when calling in ...appreciate your help,been on this for ages now ....

Paolo Bevilacqua Wed, 04/09/2008 - 03:51

There are incoming and outgoing DPs. the trunkgroup is for outgoing ones and you need it there, remove any port command you ad first.


For incoming, normally you have

dial-peer voice 1 pots

incoming called-number .

direct-inward-dial


However to ring the destination phone, the called number must match extension. This is either with a translation-profile, or dialplan pattern under telephony-service. The details varies with each installation and country.


Steellllllllll0 Wed, 04/09/2008 - 04:24

This is what my current voice config looks like :



aaa session-id common

clock timezone GMT 0

network-clock-participate wic 0

network-clock-participate wic 1

network-clock-participate wic 2


isdn switch-type basic-net3

!

!

trunk group bri

!

voice-card 0

no dspfarm

!

!



interface LoopbackXX

description VIRTUAL | LOOPBACK | Router Management | -

ip address X.X.X.X 255.255.255.255

no ip redirects

ip route-cache flow

load-interval 30

h323-gateway voip bind srcaddr X.X.X.X


interface BRI0/0/0

description SHUTDOWN |

bandwidth 64

no ip address

no ip redirects

no ip proxy-arp

ip route-cache flow

isdn switch-type basic-net3

isdn overlap-receiving

isdn incoming-voice voice

isdn sending-complete

isdn static-tei 0

trunk-group bri

!

interface BRI0/0/1

description SHUTDOWN |

bandwidth 64

no ip address

no ip redirects

no ip proxy-arp

ip route-cache flow

isdn switch-type basic-net3

isdn overlap-receiving

isdn incoming-voice voice

isdn sending-complete

isdn static-tei 0

trunk-group bri

!

interface BRI0/1/0

description SHUTDOWN |

bandwidth 1

no ip address

no ip redirects

no ip proxy-arp

ip route-cache flow

shutdown

isdn switch-type basic-net3

isdn point-to-point-setup

isdn incoming-voice voice



interface BRI0/1/1

description SHUTDOWN |

bandwidth 64

no ip address

no ip redirects

no ip proxy-arp

ip route-cache flow

isdn switch-type basic-net3

isdn overlap-receiving

isdn point-to-point-setup

isdn sending-complete

isdn static-tei 0

trunk-group bri

!

interface BRI0/2/0

description SHUTDOWN |

bandwidth 1

no ip address

no ip redirects

no ip proxy-arp

ip route-cache flow

isdn switch-type basic-net3

isdn point-to-point-setup

!

interface BRI0/2/1

description SHUTDOWN |

bandwidth 1

no ip address

no ip redirects

no ip proxy-arp

ip route-cache flow

isdn switch-type basic-net3

isdn point-to-point-setup

!

interface Serial0/3/0

description SHUTDOWN |

bandwidth 1

no ip address

no ip redirects

no ip proxy-arp

ip route-cache flow

load-interval 30

shutdown

clock rate 2000000

!

interface Serial0/3/1

description SHUTDOWN |

bandwidth 1

no ip address

no ip redirects

no ip proxy-arp

ip route-cache flow

load-interval 30

shutdown

clock rate 2000000

!

interface Dialer1

description WAN | BRI

no ip address

no ip redirects

no ip proxy-arp

encapsulation ppp

ip route-cache flow

no ip mroute-cache

load-interval 30

dialer pool 1

dialer idle-timeout 180

dialer-group 1

no keepalive

no cdp enable

ppp multilink


!

voice-port 0/0/0

!

voice-port 0/0/1

!

voice-port 0/1/0

!

voice-port 0/1/1

!

voice-port 0/2/0

!

voice-port 0/2/1

!


!

!

dial-peer voice 50 voip

destination-pattern 5446835..

session target ipv4:134.32.8.130

incoming called-number .T

!

dial-peer voice 30 pots

destination-pattern .T

incoming called-number 5446835..

direct-inward-dial

forward-digits all

!

dial-peer voice 51 voip

destination-pattern 35..

session target ipv4:134.32.8.130

incoming called-number .T

codec g711ulaw

!


At the moment if i call in from my mobile i can see the call come in but i am still getting a dial tone on my mobile.I need to translate the incoming 9 digits the carrier is presenting to four digits.All the call manager config is done and i have one DN setup for testin.

Paolo Bevilacqua Wed, 04/09/2008 - 04:42

Hi,


compare the "incoming called-number" on DP 30 with what you receive from telco as "debug isdn q931", they have to match. Or just use ".". Else you get dialtone.

The DP thing take a little to be understood, after you'll be OK.


Steellllllllll0 Wed, 04/09/2008 - 05:18

Calling Party Number i = 0x0183, '3391721202'

Plan:ISDN, Type:Unknown

Called Party Number i = 0xA1, '544683500'

Plan:ISDN, Type:National


They seem to match from the output.do i not need to do anything on the voiceports or create some translation rules.

Paolo Bevilacqua Wed, 04/09/2008 - 05:23

Yes they match. The call should be getting to the CM, it seems strange that it gives dialtone but I cannot exclude that. Check with "debug voip dialpeer".

Steellllllllll0 Wed, 04/09/2008 - 23:58

There is no match on debug dial-peer and the output from the sh DP voice shows operation state & outbound state as down :


peer type = voice, information type = voice,

description = `',

tag = 30, destination-pattern = `.T',

answer-address = `', preference=0,

CLID Restriction = None

CLID Network Number = `'

CLID Second Number sent

CLID Override RDNIS = disabled,

source carrier-id = `', target carrier-id = `',

source trunk-group-label = `', target trunk-group-label = `',

numbering Type = `unknown'

group = 30, Admin state is up, Operation state is down,

Outbound state is down,

incoming called-number = `5446835..', connections/maximum = 0/unlimited,

DTMF Relay = disabled,

URI classes:

Destination =

huntstop = disabled,

in bound application associated: 'DEFAULT'

out bound application associated: ''

dnis-map =

permission :both

incoming COR list:maximum capability

outgoing COR list:minimum requirement

Translation profile (Incoming):

Translation profile (Outgoing):

incoming call blocking:

translation-profile = `'

disconnect-cause = `no-service'

advertise 0x40 capacity_update_timer 25 addrFamily 4 oldAddrFamily 4

type = pots, prefix = `',

forward-digits all

session-target = `', voice-port = `',

direct-inward-dial = enabled,

digit_strip = enabled,

register E.164 number with H323 GK and/or SIP Registrar = TRUE

fax rate = system, payload size = 20 bytes

supported-language =

Paolo Bevilacqua Thu, 04/10/2008 - 00:04

Admin state is up and that's what matters.

Oper state is down due to no active calls. Outbound is down due to lack of destination-pattern and port, however being this an incoming DP, that doesn't matter.

Do you have any translation rule ? Try "incoming called-number ." as suggested above.

Steellllllllll0 Thu, 04/10/2008 - 00:57

The incoming called number is added to the dial peers.I dont have any translation rules setup.

This is doing my head in :-)

Steellllllllll0 Thu, 04/10/2008 - 01:36

I added the port numbers to the dial-peers and am now able to receive calls but unable to make any.

Actions

This Discussion