Using LMS 2.6 to upload/download to 3560 using ssh

Unanswered Question
Apr 9th, 2008

We configured a client on ACS 3.3 to access the 3560 using ssh. Now i want to use LMS to make config changes, download software, etc. I created an account on ACS & edited the device credentials in the device center but, can't download ios using rme 4.05. Any help would be appreciated?


thanks,

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Wed, 04/09/2008 - 08:53

You will need to go to RME > Admin > Software Mgmt > View/Edit Preferences, and check the enable SSH box. Then, RME will use SSH when it needs to work interactively with a device. For a 3560, RME will log into the device either via telnet or SSH (based on that checkbox), then perform a copy on the switch.

czarman Wed, 04/09/2008 - 10:25

I tried that & it still won't work. I'm not sure what is missing.

Joe Clarke Wed, 04/09/2008 - 22:59

You will need to enable SoftwareManagement debugging under RME > Admin > System Preferences > Loglevel Settings. Then re-run your job. The job directory under NMSROOT\files\rme\jobs\swim will have the details as to what is going wrong.

czarman Thu, 04/24/2008 - 03:18

Ok, it took a while but, I got the log. When i turn off ssh I can download software to the same switch w/o any problems. I've attached the log. What do you think?



Attachment: 
Joe Clarke Thu, 04/24/2008 - 08:36

According to this, SSH authentication is failing. Make sure you have configured the same username and password configured for this device in DCR. Note: where as telnet can be successfully authenticated with a password alone, SSH requires both a username and a password.

Actions

This Discussion