Controlling Rip metrics

Answered Question
Apr 9th, 2008

Hi have a quick quesiton I have 2 routes on a customer site one is primary and one is backup. They are running rip and I'm running OSPF. What I was looking to do is having all the RIP updates from the customer come over the primary link and if that goes away then the secondary will take over. I was going to control that via redistribution or is there a better way? My config are:

router rip

version 2

redistribute ospf 1 metric 10 route-map redis-to-Napa

passive-interface Serial0/0

passive-interface BRI0/0

network 172.16.0.0

distribute-list prefix plist-to-Napa out

distribute-list prefix plist-from-Napa in

distance 75

no auto-summary

router rip

version 2

redistribute ospf 1 metric 5 route-map redis-to-Napa

passive-interface Serial0/0.100

network 172.16.0.0

distribute-list prefix plist-to-Napa out

distribute-list prefix plist-from-Napa in

distance 75

no auto-summary

I have this problem too.
0 votes
Correct Answer by sundar.palaniappan about 8 years 7 months ago

Warren,

With redistribution from OSPF -> RIP you would be able to influence how your customer would route traffic to you. Also, factor what Edison said about the route becoming unreachable when the hop count becomes 16.

Your configuration doesn't show how the traffic from your network goes to the customer. You can do that several different ways.

1. When you redistribute RIP into OSPF you can set the metric to be preferred for the route that's advertised out of the primary router.

2. You can use an offset list under RIP for routes learned from the customer and set the metric preferred for the primary route.

HTH

Sundar

Correct Answer by Edison Ortiz about 8 years 7 months ago

Hi there,

It's fine the way you are doing it. One caveat, watch out for the hop count as you are bringing external RIP routes with Metric 10. Once the Metric becomes 16, the route is invalid. Not sure how many hops you have to other RIP routers from this router.

HTH,

__

Edison.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
Edison Ortiz Wed, 04/09/2008 - 13:27

Hi there,

It's fine the way you are doing it. One caveat, watch out for the hop count as you are bringing external RIP routes with Metric 10. Once the Metric becomes 16, the route is invalid. Not sure how many hops you have to other RIP routers from this router.

HTH,

__

Edison.

Correct Answer
sundar.palaniappan Wed, 04/09/2008 - 14:03

Warren,

With redistribution from OSPF -> RIP you would be able to influence how your customer would route traffic to you. Also, factor what Edison said about the route becoming unreachable when the hop count becomes 16.

Your configuration doesn't show how the traffic from your network goes to the customer. You can do that several different ways.

1. When you redistribute RIP into OSPF you can set the metric to be preferred for the route that's advertised out of the primary router.

2. You can use an offset list under RIP for routes learned from the customer and set the metric preferred for the primary route.

HTH

Sundar

wgranada1 Thu, 04/10/2008 - 05:41

Hi Sundar and Edison

Thank you guys for your input really helps, I wasn't sure if what I was doing was correct till you guys verfied it. As far as my traffic going back to them. Under my ospf statement Ihave the following:

router ospf 1

router-id 172.19.105.6

log-adjacency-changes

redistribute connected subnets route-map redis-connected

redistribute rip metric 10 subnets route-map redis-from-Napa

network 172.19.25.60 0.0.0.3 area 1

Actions

This Discussion