Presence line status not working

Unanswered Question
Apr 9th, 2008

Everything on my CUCM 6.1 and CUPC 6.0 is working fine. SIP calls, IM, IM status, phone control, etc. But I can not for the life of me get the on/off hook status to work at all. (if the contact is on the phone, the phone status shows the little phone icon as off hook, etc)

I know it's in the SIP trunk because that is what it describes in the description of the trunk. (control for on/off hook). But what is odd, my SIP clients register, can make calls, receive calls etc. But the "presence" of the line to monitor will not work.

I have the line associated to the CUPC user ID.

My SIP messages in the logs are not telling me much either. I keep on getting this message:

CLID::StandAloneCluster><NID::172.17.241.10><LVL::All><MASK::ffff>

04/10/2008 09:31:54.843 ESP|PID(561) Response dropped, reason: Message is incomplete or not properly terminated

|<CLID::StandAloneCluster><NID::172.17.241.10><LVL::All><MASK::ffff>

04/10/2008 09:35:52.248 ESP|PID(561) sip_protocol.c(5685) First line of message is Bad

|<CLID::StandAloneCluster><NID::172.17.241.10><LVL::All><MASK::ffff>

04/10/2008 09:35:52.248 ESP|ID(561) Response dropped, reason: Message is incomplete or not properly terminated

|<CLID::StandAloneCluster><NID::172.17.241.10><LVL::All><MASK::ffff>

04/10/2008 09:35:54.793 ESP|PID(929) sip_protocol.c(5685) First line of message is Bad

Thanks!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
abcronin Sun, 04/20/2008 - 13:11

Hi there

I am getting the exact same issue with CUCM 6.1 and CUPS 6.0 (CUPC 1.2(2)).

Did you have any luck getting it working? It's a bit pointless having a presence client that doesn't show the presence :-(

I think it may be a bug....I am going to log a TAC case.

Cheers

Andy

Tommer Catlin Mon, 04/21/2008 - 07:23

It was a couple of things. One was I did not have my ACL incoming and Outgoing set "all"

There was also an Enterprise parameter for Presence Engine, but I would have to dig it up. If I find it today, I will post it back here

ian.mcguinness Wed, 04/23/2008 - 01:50

Hi,

I am also having the exact same issue with off hook on hook on CUPS 1.0(3) And CM 5.0(4). Cn you let me know what you changed

Tommer Catlin Wed, 04/23/2008 - 07:35

Try these:

Make sure you have Proxy Profile for the CUPC users. (User Management, Proxy Profile)

In the System/ Service parameters

Select server

Select service Presence Engine

In the "Enterprise Service Contact Name:

Enter in: 172.17.241.10:5070;transport=tcp

The 172 is my CUPS server.

mknepper Sat, 05/31/2008 - 23:21

So is the expected behavior to display line presence for all phones that are in the SUBSCRIBE CSS or does CUPC just show the line presence of those users logged into CUPC. I am trying to determine if this is the similar to Attendant Console's ability to "monitor" line states across the organization.

Tommer Catlin Sun, 06/01/2008 - 19:52

I believe the CUPC just shows the line presence of the line that is subscribed in CSS. If SUBSCRIBE CSS is not selected, the CUPC will not show on/off hook in the client.

f.giordano Wed, 06/18/2008 - 00:46

Hi Tommer,

I'm having the same issue like you.

Everything is working fine except on hook/off hook status in CUPC.

I'm running CUCM 6.2(1) and CUPS 6.0.3.

My troubleshooter is green everywhere. But contrary to you, I didn't find anything tips to resolve it. I already check all you said in your previous post and no more idea now.

Maybe you have an idea ?

Thx for it

Fabian

Tommer Catlin Wed, 06/18/2008 - 08:11

If you are running (2) CUPS servers, take the second one down. Also reboot the primary cups server. Log out of the CUPC client and log back in.

You can also check the log files on the client it self. Enable logging and post those up. Maybe we can see where it is getting hung up.

f.giordano Thu, 06/19/2008 - 06:30

No only one server for me.

I attached the log files, but it's a little bit I don't find anything wrong. I can see an error with proxy (not started) or something like that but it makes no sense...

Thx for ur help

Fabian

Actions

This Discussion