LMS 3.0.1 Excessive growing Daemons.log file

Unanswered Question
Apr 9th, 2008
User Badges:

On a Solaris system with LMS 3.0.1 in Multi-server trust (Dec-Update) the daemons.log file on the Campus/RME (DCR-Master) server is growing excessive. Currently 17 Gb (uptime 3 days).


It shows java.net.ConnectException: Connection refused (see attachment)


The system seems to work fine, except for this issue.



Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Wed, 04/09/2008 - 16:43
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

This will occur when Config Archive runs if your selected protocol order under RME > Admin > Config Mgmt > Transport Settings is not as correct as it can be. In any event, you can manage the size of daemons.log using the NMSROOT/bin/logrot.pl tool. First, run NMSROOT/bin/logrot.pl -c to configure log rotation. Specify the path to daemons.log, how large you want the file to be able to grow, and how many archives to keep (if any). then add a cron entry to run logrot.pl as often as you need (e.g. once per day).


More on logrot can be found in the Common Services online help.

vergeerf Wed, 04/09/2008 - 23:13
User Badges:

thanks, I've indeed changed the order of the transport protocol i.e. removed telnet from the list because the customer's network does use SSH. So It shouldn't report a connection refused. Is there a way to find out what devices in the DCR are causing this?


In the mean time I will setup a cronjob with logrot.

Joe Clarke Thu, 04/10/2008 - 08:29
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

There isn't an easy way to determine this. But if you have disabled telnet from your allowed protocols, you should not enter this code path anymore.

What if there is certain devices such as the 3500 switch that can't run SSH? We must have the telnet active for that reason, and now our daemons.log is at 11GB after only 24 hours....

I did a

grep "java.net.ConnectException: Connection refused" daemons.log | wc

and got this, 5937014 <---!!!

That is almost 6 million occurrencies, and have in mind that this is only the firs row of 22. 6x22x1000000 rows of pure junk.

There must be a way to shut of this kind of java logging?

Joe Clarke Mon, 06/09/2008 - 22:12
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

There is no way to disable this logging. However, I have developed a patch for bug CSCso57052 which will help reduce the amount of these connection refused exceptions. The patch doesn't actually address the logging issue, but it greatly cuts down on the number of connections attempted, and thus will reduce the logging.


For example, before the patch, you could get, say, 100 connections per device. After the patch there will never be more than three.


You can contact the TAC, and reference the above bug to get the patch.

yjdabear Tue, 06/10/2008 - 06:57
User Badges:
  • Gold, 750 points or more

Is this patch going to be in LMS 3.1?

Joe Clarke Tue, 06/10/2008 - 08:40
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Yes.

Actions

This Discussion