GW not registering on a GK

Answered Question
Apr 9th, 2008
User Badges:

Hi,


I`ve 2 GKs and a group of 10 GWs that I'm cofiguring to register against the GKs.


I've configured ok 3 GWs, but when I configure the fourth it doesn't register. The configuration is the same on this GW.


This is the configuration for a GW that is registered with the GK


interface Ethernet0/0

ip address 10.180.67.200 255.255.255.0

half-duplex

fair-queue

h323-gateway voip interface

h323-gateway voip id gk01.demo.cl ipaddr 10.179.200.20 1719 priority 120

h323-gateway voip id gk02.demo.cl ipaddr 10.177.50.20 1719

h323-gateway voip h323-id gw_talca

h323-gateway voip tech-prefix 1#

h323-gateway voip bind srcaddr 10.180.67.200


Talca#sh gatew

Gateway gw_talca is registered to Gatekeeper gk01.demo.cl


Alias list (CLI configured)

H323-ID gw_talca

Alias list (last RCF)

H323-ID gw_talca


H323 resource thresholding is Disabled

Permanent Alternate Gatekeeper List

priority 120 id gk01.demo.cl ipaddr 10.179.200.20 1719 register needed

priority 127 id gk02.demo.cl ipaddr 10.177.50.20 1719 register needed

Primary gatekeeper ID gk01.demo.cl ipaddr 10.179.200.20 1719


2.- This is the configuration of the Gw that doesn't register:


interface Ethernet0/0

ip address 10.180.65.200 255.255.255.0

full-duplex

fair-queue

h323-gateway voip interface

h323-gateway voip id gk01.demo.cl ipaddr 10.179.200.20 1719 priority 120

h323-gateway voip id gk02.demo.cl ipaddr 10.177.50.20 1719

h323-gateway voip h323-id gw_concepcion_2

h323-gateway voip tech-prefix 1#

h323-gateway voip bind srcaddr 10.180.65.200


sh gatew

Gateway gw_concepcion_2 is not registered to any gatekeeper


Alias list (CLI configured)

H323-ID gw_concepcion_2

Alias list (last RCF) is empty


Non Permanent Alternate Gatekeeper List

priority 120 id gk01.demo.cl ipaddr 10.179.200.20 1719 register needed

priority 127 id gk02.demo.cl ipaddr 10.177.50.20 1719 register needed


3) This is the configuration on GK01


gatekeeper

zone local gk01.demo.cl demo.cl 10.179.200.20

zone remote gk02.demo.cl demo.cl 10.177.50.20 1719

zone prefix gk01.demo.cl 31.. gw-priority 10 gw_talca

zone prefix gk01.demo.cl 32.. gw-priority 10 gw_chillan

zone prefix gk01.demo.cl 37.. gw-priority 10 gw_osorno

gw-type-prefix 1#* default-technology

no shutdown


GK-1#sh gatek end

GATEKEEPER ENDPOINT REGISTRATION

================================

CallSignalAddr Port RASSignalAddr Port Zone Name Type Flags

--------------- ----- --------------- ----- --------- ---- -----

10.180.18.200 1720 10.180.18.200 53275 gk01.demo.cl VOIP-GW

H323-ID: gw_osorno

Voice Capacity Max.= Avail.= Current.= 0

10.180.66.200 1720 10.180.66.200 54543 gk01.demo.cl VOIP-GW

H323-ID: gw_chillan

Voice Capacity Max.= Avail.= Current.= 0

10.180.67.200 1720 10.180.67.200 53931 gk01.demo.cl VOIP-GW

H323-ID: gw_talca

Voice Capacity Max.= Avail.= Current.= 0

Total number of active registrations = 3


I've tried shutting down the GK01, and the 3 GWs registers against GK02. Then starting GK01 and the same 3 GWs register against it.


Ì've tried with 2 different gateways,and they didn't register. Only the same 3 GWs.


GK is running c2800nm-ipvoice_ivs-mz.124-8.bin


Any suggestion will be glad received.


TIA

Andres Pasten

Correct Answer by gogasca about 9 years 1 month ago

Hi Andres,

Perfomr a debug h225 asn1 in the GW which is failing also in GK

Do a no gateway, then gateway in config mode

Make sure u can ping from src IP

10.180.65.200

to 10.179.200.20


and let us know

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
Correct Answer
gogasca Wed, 04/09/2008 - 19:57
User Badges:
  • Green, 3000 points or more

Hi Andres,

Perfomr a debug h225 asn1 in the GW which is failing also in GK

Do a no gateway, then gateway in config mode

Make sure u can ping from src IP

10.180.65.200

to 10.179.200.20


and let us know

andres.pasten Tue, 04/15/2008 - 14:47
User Badges:

Hi,


When I've done a no gateway and then gateway, the gateway has registered on the GK. I've tested it on 2 GWs and worked fine.


So now I'm intrigued why I was able to register the first 3 GWs if I've not done the "no gateway/gateway".


TIA

Andres

madan.kumar Mon, 08/11/2008 - 01:37
User Badges:

Hi


I'm trying a scenario of 2 GW's and a GK

Am able to register 1 GW without any issues

the other one is not registering tried no gateway/gateway and debug h225 asn1 & debug ras doesnt gives any output, Able to ping from source IP's


Attached is the config i'm trying


Thanks



Attachment: 
andres.pasten Mon, 08/11/2008 - 05:25
User Badges:

Hi,


On the GK config, the zone local defines the GK name and his IP Address, not the GWs names.


So if the names and IP's are this way:

IP Name

30.1.1.3 GK.cisco.com

30.1.1.1 Boise

30.1.1.2 Miami


The configs should be:

a) GK

gatekeeper

zone local GK.cisco.com cisco.com 30.1.1.3

no shutdown


b)Boise

BoiseGW-Config

**************


interface GigabitEthernet0/1.1

encapsulation dot1Q 1 native

ip address 30.1.1.1 255.255.255.0

no snmp trap link-status

h323-gateway voip interface

h323-gateway voip id GK.cisco.com ipaddr 30.1.1.3 1719

h323-gateway voip h323-id [email protected]

h323-gateway voip tech-prefix 1#

h323-gateway voip bind srcaddr 30.1.1.1


c) Miami


interface GigabitEthernet0/0.1

description TO-GK

encapsulation dot1Q 1 native

ip address 30.1.1.2 255.255.255.0

no snmp trap link-status

h323-gateway voip interface

h323-gateway voip id GK.cisco.com ipaddr 30.1.1.3 1719

h323-gateway voip h323-id [email protected]

h323-gateway voip tech-prefix 1#

h323-gateway voip bind srcaddr 30.1.1.2


See you.

Andres Pasten

Adexus S.A.

madan.kumar Mon, 08/11/2008 - 06:40
User Badges:

Hi


Its so kind of you i had done the replica of the config you provided, it was not registering then also tried adding the session target ras(as per other netpro) in miami, It got registerd

4 points to u

Thank u


Actions

This Discussion