performance troubleshooting

Unanswered Question

using a Cisco 2960 switch I get very poor connection to the network

other switches on the network allow a fast reliable connection.

when I switch a PC from this 2960 to other switches the performance boost immediately

how do I troubleshoot and find the reason? (it is a new out of the box switch so I guess it is a config issue and not hardware related)


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
sundar.palaniappan Wed, 04/09/2008 - 14:43

I don't know if you have already configured portfast on the access ports. If it isn't can you configure 'spanning-tree portfast' on the ports connected to PCs and see if that helps.


If you are still having issues can you give more details of your problem.


HTH


Sundar

this is the port config:

interface FastEthernet0/16

description ***

switchport access vlan 201

switchport mode access

speed 100

duplex full


FastEthernet0/16 is down, line protocol is down (notconnect)

Hardware is Fast Ethernet, address is 001b.2aaf.a490 (bia 001b.2aaf.a490)

Description: ***

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, media type is 10/100BaseTX

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output 04:16:48, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

23123090 packets input, 3306271391 bytes, 0 no buffer

Received 797083 broadcasts (0 multicast)

3 runts, 0 giants, 0 throttles

70945 input errors, 70654 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 274522 multicast, 0 pause input

0 input packets with dribble condition detected

1004846643 packets output, 2307488030 bytes, 0 underruns

0 output errors, 0 collisions, 1 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out


it is a plain LAn with few VLANs


what other data would help here?

sundar.palaniappan Wed, 04/09/2008 - 14:54

As you can see there is a lot of CRC errors on the port. It can be due to a duplex issue, bad cable, port, NIC etc. As a first step, can you use the following configuration and see if it helps.


interface FastEthernet0/16

description ***

switchport access vlan 201

switchport mode access

speed auto

duplex auto

spanning-tree portfast


HTH


Sundar

sundar.palaniappan Wed, 04/09/2008 - 15:27

It could be duplex mismatch between the switch and PC NICs. If you have the NIC duplex set to auto negotiate I would suggest using the duplex to auto on the switch port and see that indeed is the problem here.

Actions

This Discussion