E1 trunk between Cisco E1/T1 module and Digium TE207 PRI Card

Unanswered Question
Apr 10th, 2008

Hi all, I'm trying to make a E1 trunk between Cisco and Asterisk but I have some problem with controller configuration.

Tests with loopback cable are ok in both parties.

This is my cisco conf:

network-clock-participate wic 3

network-clock-select 1 E1 0/3/0

isdn switch-type primary-net5


voice-card 0

dsp services dspfarm

controller E1 0/3/0

pri-group timeslots 1-31

interface Serial0/3/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bchan-number-order ascending

no cdp enable

voice-port 0/3/0:15


echo-cancel coverage 48

no vad

no comfort-noise

cptone IT

timeouts interdigit 3

And this is the output of sh controller E1

sh controllers E1

E1 0/3/0 is down.

Applique type is Channelized E1 - balanced

Transmitter is sending remote alarm.

Receiver has loss of frame.

alarm-trigger is not set

Version info Firmware: 20060711, FPGA: 13, spm_count = 0

Framing is CRC4, Line Code is HDB3, Clock Source is Line.

CRC Threshold is 320. Reported from firmware is 320.

Data in current interval (619 seconds elapsed):

1 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 619 Unavail Secs

I use one cross cable with 1-4 and 2-5 pin crossed.

In the card I have a green led and one orange led on "AL"

anyone can help me? I think the problem is Cisco side because in Asterisk seems all ok.

Thanks in advantage

I have this problem too.
1 vote
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Paolo Bevilacqua Thu, 04/10/2008 - 02:57

Hi, your pinout is wrong, should be 1-2 going to 4-5.

Hope this helps, please rate post if it does!

epasqualotto Thu, 04/10/2008 - 03:57

Yes, my cable is correct: 1 -> 4 and 2 -> 5.

Clock source problem is possible?

Paolo Bevilacqua Thu, 04/10/2008 - 04:43

Yes, clock source should be router and isdn protocol-emulate network. Don't mess with bchan-order and pi_disc unless you know there is a problem in there.

jose.ignacio Tue, 08/12/2014 - 20:24

Please can you send me the Asterisk configuration files (system.conf and dahdi_channels.conf), I have this problem since 1 year and I can not solve it. Thank you for you help.


This Discussion